Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Problems installing IAM - bundles are missing
Problems installing IAM - bundles are missing [message #17484] Sun, 29 March 2009 06:04 Go to next message
Carsten Ziegeler is currently offline Carsten Ziegeler
Messages: 4
Registered: July 2009
Junior Member
Hi,

I'm running plain 3.4.1 (with WTP, svn support, mylyn etc.), and I'm
trying to install IAM from the dev updatesite (it's version
0.9.0.200903242053)
I get the following error:
An error occurred while collecting items to be installed
No repository found containing:
com.ibm.etools.emf.event/osgi.bundle/3.0.0.v20060918_M
No repository found containing:
org.apache.jakarta_log4j/osgi.bundle/1.2.8.v200607172048


Regards
Carsten
Re: Problems installing IAM - bundles are missing [message #17487 is a reply to message #17484] Sun, 29 March 2009 06:45 Go to previous messageGo to next message
Carsten Ziegeler is currently offline Carsten Ziegeler
Messages: 4
Registered: July 2009
Junior Member
Ok, found the problem. With SR2 installation works perfect, but with the
older SR1 it doesn't work as shown above.

Carsten
Re: Problems installing IAM - bundles are missing [message #17490 is a reply to message #17487] Sun, 29 March 2009 08:47 Go to previous messageGo to next message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Good you found the cause.

It is true that we are running the dev build with SR2 as our target
platform, but that should not affect the minimum versions... anything
shipped in SR1 (or "SR0" should work).

I've filed a bug for this
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270383 and will take a look
at it.

Carsten Ziegeler wrote:

> Ok, found the problem. With SR2 installation works perfect, but with the
> older SR1 it doesn't work as shown above.

> Carsten
Re: Problems installing IAM - bundles are missing [message #17492 is a reply to message #17490] Sun, 29 March 2009 10:36 Go to previous message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
I've done a quick test on two setups:
- Clean Eclipse SDK 3.4.0
- Use update manager to install P2 and IAM (no SVN/Buckminster
integration)

- Eclipse SDK 3.4.1 + WTP + Dependencies
- Use update manager to install IAM (no SVN/Buckminster integration)

Both installed successfully (P2 automatically fetches some extra jars from
the Ganymede update site).

As a note, with WTP installed I've got some problems with P2 (features
showing 3 times, no categories), so I did a "Refresh" from the update
manager UI before installing.

I'm closing https://bugs.eclipse.org/bugs/show_bug.cgi?id=270383 as "works
for me", but if you can provide a way to reproduce the problem, please
reopen it.

Yours,
Abel.
Re: Problems installing IAM - bundles are missing [message #568693 is a reply to message #17484] Sun, 29 March 2009 06:45 Go to previous message
Carsten Ziegeler is currently offline Carsten Ziegeler
Messages: 4
Registered: July 2009
Junior Member
Ok, found the problem. With SR2 installation works perfect, but with the
older SR1 it doesn't work as shown above.

Carsten
Re: Problems installing IAM - bundles are missing [message #568699 is a reply to message #17487] Sun, 29 March 2009 08:47 Go to previous message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Good you found the cause.

It is true that we are running the dev build with SR2 as our target
platform, but that should not affect the minimum versions... anything
shipped in SR1 (or "SR0" should work).

I've filed a bug for this
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270383 and will take a look
at it.

Carsten Ziegeler wrote:

> Ok, found the problem. With SR2 installation works perfect, but with the
> older SR1 it doesn't work as shown above.

> Carsten
Re: Problems installing IAM - bundles are missing [message #568713 is a reply to message #17490] Sun, 29 March 2009 10:36 Go to previous message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
I've done a quick test on two setups:
- Clean Eclipse SDK 3.4.0
- Use update manager to install P2 and IAM (no SVN/Buckminster
integration)

- Eclipse SDK 3.4.1 + WTP + Dependencies
- Use update manager to install IAM (no SVN/Buckminster integration)

Both installed successfully (P2 automatically fetches some extra jars from
the Ganymede update site).

As a note, with WTP installed I've got some problems with P2 (features
showing 3 times, no categories), so I did a "Refresh" from the update
manager UI before installing.

I'm closing https://bugs.eclipse.org/bugs/show_bug.cgi?id=270383 as "works
for me", but if you can provide a way to reproduce the problem, please
reopen it.

Yours,
Abel.
Previous Topic:Problems installing IAM - bundles are missing
Next Topic:Release candidate 0.9.0 at Q4E
Goto Forum:
  


Current Time: Wed Jul 30 19:34:46 EDT 2014

Powered by FUDForum. Page generated in 0.07325 seconds