Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Failed to execute MI command -exec -run(Failed to execute MI command -exec -run)
Failed to execute MI command -exec -run [message #1173501] Wed, 06 November 2013 15:11 Go to next message
Klemens Barfus is currently offline Klemens Barfus
Messages: 1
Registered: November 2013
Junior Member
Hi all,

I try to debug a makefile project with eclipse, cygwin and mingw in Windows. When I start the debugging, I get the error message

'Failed to execute MI command -exec -run'

When I check Preferences > Debug I just find a GDB but not a GDB MI tab as it is shown in some manuals.

I also do not have an idea where the MI command '-exec -run' is specified.

What's wrong with my installation or setup ?

Thanks for your help in advance.

Klemens
Re: Failed to execute MI command -exec -run [message #1176914 is a reply to message #1173501] Fri, 08 November 2013 16:45 Go to previous message
Marc Khouzam is currently offline Marc Khouzam
Messages: 278
Registered: July 2009
Senior Member
With the new CDT GDB integration, there is no more GDB/MI preference page.

-exec-run is meant for running a new process, while -exec-continue should be used when you connect to an already running process.
It is possible that your scenario already has the process running but Eclipse does not realize it.
You may be using the wrong launch type. Try using C/C++ Remote application but switch to the manual delegate:,
or you can try using the old GDB integration:
https://wiki.eclipse.org/CDT/User/FAQ#How_can_I_choose_another_debugger_integration_for_CDT.3F

Marc
Previous Topic:Eclipse's new scanner discovery does not detect -isystem includes
Next Topic:GNU multi-precision library in Eclipse CDT
Goto Forum:
  


Current Time: Wed Oct 01 16:20:32 GMT 2014

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software