Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Hudson plugin update for subversion 1.8 compatibility(Unable to use the latest subversion 1.8 with Hudson 3.1.0 and subversion plugin 2.3.8-h-1)
icon5.gif  Hudson plugin update for subversion 1.8 compatibility [message #1169951] Mon, 04 November 2013 09:54 Go to next message
Laurent Mercier is currently offline Laurent Mercier
Messages: 2
Registered: November 2013
Junior Member
Hello,

We are currently using Hudson 3.1.0 with the subversion plugin 2.3.8-h-1 and would like to update to the latest SVN version (i.e. v1.8, released in June 2013). Unfortunately, the current subversion plugin does not seem to support this version and was not updated since February 2013.

Does anyone have had the same problem recently or know whether the HUDSON subversion plugin is still maintained and if/when it will be updated?

Thank you for your help!

Laurent
Re: Hudson plugin update for subversion 1.8 compatibility [message #1170329 is a reply to message #1169951] Mon, 04 November 2013 15:11 Go to previous messageGo to next message
Geoff Waymark is currently offline Geoff Waymark
Messages: 26
Registered: July 2012
Junior Member
The subversion plugin uses the svnkit java library which currently does not support 1.8.

Once svnkit is available for 1.8 then the plugin can be updated, the current svnkit 1.8 is in beta 2.

Thanks

Geoff


Geoff Waymark
Eclipse Hudson team
Re: Hudson plugin update for subversion 1.8 compatibility [message #1170347 is a reply to message #1170329] Mon, 04 November 2013 15:27 Go to previous messageGo to next message
Laurent Mercier is currently offline Laurent Mercier
Messages: 2
Registered: November 2013
Junior Member
Thank you for your reply Geoff.

Best,
Laurent
Re: Hudson plugin update for subversion 1.8 compatibility [message #1174868 is a reply to message #1170347] Thu, 07 November 2013 11:09 Go to previous message
Geoff Waymark is currently offline Geoff Waymark
Messages: 26
Registered: July 2012
Junior Member
Svnkit 1.8.0 RC1 has just been released so it looks like this is getting closer.

I've logged this bug - https://bugs.eclipse.org/bugs/show_bug.cgi?id=421233 to track the upgrade

Thanks,
Geoff


Geoff Waymark
Eclipse Hudson team
Previous Topic:GIT - clean checkout fails
Next Topic:Lunch build from another job list
Goto Forum:
  


Current Time: Tue Oct 21 07:07:05 GMT 2014

Powered by FUDForum. Page generated in 0.02484 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software