Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EJB3 in EAR
EJB3 in EAR [message #181921] Wed, 25 October 2006 16:45 Go to next message
Eclipse User
Originally posted by: andrey.nechet.gmail.com

Hi,

I would like to prepare the EAR file with ejb3 module (ejb3.jar for example)
for deploing into the JBoss.
The problem in EJB project - only facets for 2.0/2.1 ejb supported.
I'm trying to remove the META-INF/ejb-jar.xml from EJB project, but then the
final EAR file missing the ejb module (ejb3.jar).

Andrey
Re: EJB3 in EAR [message #181957 is a reply to message #181921] Fri, 27 October 2006 06:28 Go to previous messageGo to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi Andrey,

you have to modify the deployment descriptors to match JavaEE5. I use a modified
JBoss plugin for EJB3 development
(http://www.informatik.fh-wiesbaden.de/~knauf/public/), and with some tricks I
can use WTP 1.5 quite well.

I create a new project with a 2.1 facet, then change "ejb-jar.xml" to match
EJB3. The necessary changes and a sample project can be found at the above URL.

Hope this helps

Wolfgang

Andrey Nechet schrieb:
> Hi,
>
> I would like to prepare the EAR file with ejb3 module (ejb3.jar for example)
> for deploing into the JBoss.
> The problem in EJB project - only facets for 2.0/2.1 ejb supported.
> I'm trying to remove the META-INF/ejb-jar.xml from EJB project, but then the
> final EAR file missing the ejb module (ejb3.jar).
>
> Andrey
>
>
Re: EJB3 in EAR [message #181973 is a reply to message #181957] Fri, 27 October 2006 14:05 Go to previous message
Eclipse User
Originally posted by: andrey.nechet.gmail.com

Hi Wolfgang,

Your trick is work for me :)
Thank you a lot!

Andrey


"Wolfgang Knauf" <wknauf_NO_@_INSIDE_hg-online.de> wrote in message
news:ehsmvd$8id$1@utils.eclipse.org...
> Hi Andrey,
>
> you have to modify the deployment descriptors to match JavaEE5.
Previous Topic:2.0M2-Or -1.5.2 ?????
Next Topic:JSP "run on server" acts strangely after adding servlet to project
Goto Forum:
  


Current Time: Thu Jul 31 11:40:41 EDT 2014

Powered by FUDForum. Page generated in 0.02841 seconds