Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Standalone 7.2 incompatibility with Eclipse plugin(Current Eclipse plugin does not with database from Jubula 7.2 standalone)
Standalone 7.2 incompatibility with Eclipse plugin [message #1161118] Tue, 29 October 2013 11:45 Go to next message
Bernard Rossi is currently offline Bernard Rossi
Messages: 9
Registered: October 2013
Junior Member
This was reported in an earlier thread (Jubula and GUIdancer Version 7.2 released ), but it should be a new topic. I anticipate users would want to go back and forth between the standalone Jubula and eclipse with the Jubula plugin. The plugin is not able to open the database that Jubula 7.2 uses to store projects:

"I notice that the most recent Kepler Eclipse plugin still uses the old database. I discovered this when switching between the standalone version of Jubula and Kepler eclipse with the Jubula plugins."

"Will there be an updated set of Jubula plugins?"

"Bernard"

Re: Jubula and GUIdancer Version 7.2 released [message #1154278 is a reply to message #1153411] Fri, 25 October 2013 01:15
Alexandra Schladebeck

"Hi Bernard,"

"Normally, we sync up the releases with the major milestone (i.e. Luna), but I'll check internally."

"Alex"

Re: Standalone 7.2 incompatibility with Eclipse plugin [message #1202518 is a reply to message #1161118] Fri, 22 November 2013 02:20 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1046
Registered: July 2009
Senior Member
Hi Bernard,

Thanks for adding the new thread, and sorry it took a while.

We've added a BREDEX update site for the Kepler SR1 release:
http://update.bredex.de/jubula/jubula22site

When I tried it out, my steps were as follows:
- Perform an export all of my current SR1 database
- Install the update
- Restart on prompt
- After the restart, configure a new database in the preferences (this is necessary, because the database (driver) versions are different).
- Connect to the new database
- Import the projects

That's the overview. I would strongly recommend reading the full migration information though.

I haven't tried the scenario out, but a colleague mentioned that if anyone is not working with Eclipse for Testers, then the suggested migration would be to first completely deinstall the Jubula feature, then install the update (of course also performing all necessary back up steps first).

Best regards,
Alex


Re: Standalone 7.2 incompatibility with Eclipse plugin [message #1202526 is a reply to message #1202518] Fri, 22 November 2013 02:25 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1046
Registered: July 2009
Senior Member
One more piece of information -clean is your friend when starting the new version Smile
Re: Standalone 7.2 incompatibility with Eclipse plugin [message #1203658 is a reply to message #1202526] Fri, 22 November 2013 14:35 Go to previous message
Bernard Rossi is currently offline Bernard Rossi
Messages: 9
Registered: October 2013
Junior Member
Thank you Alexandra. This will be a big help for anyone using both the Jubula Standalone 7.2 and the Jubula eclipse feature.

Today, I was able to install the new Jubula feature to kepler eclipse on Windows 7. It was able to open and use test projects that had ben created with the Jubula 7.2 standalone. I had not installed the previous version of the Jubula feature to eclipse on this Windows 7 platform.

I will verify the procedure for removing the old feature and installing the new Jubula 2.2 feature on a Linux platform. This is where the original conflict in databases was found.

Bernard Rossi
Previous Topic:executable jar with datafiles for Jubula
Next Topic:different unbound_module versions in standalone and eclipse plugin
Goto Forum:
  


Current Time: Wed Apr 16 00:40:53 EDT 2014

Powered by FUDForum. Page generated in 0.01540 seconds