Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WSDL user group
WSDL user group [message #181688] Tue, 17 October 2006 12:09 Go to next message
Eclipse User
Originally posted by: spruitt.exstream.com

Can someone recommend a WSDL user / mailing group? I can't seem to locate
one by searching.

I'm have WSDL validation errors I don't understand and I am looking for an
appropriate list to gather some advice.

Thanks.

-S
Re: WSDL user group [message #181690 is a reply to message #181688] Tue, 17 October 2006 14:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Steve, if they are WSDL validation errors generated by the WST WSDL
validator you can post to this list.

Regards,
Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eh2v7l$kco$1@utils.eclipse.org...
> Can someone recommend a WSDL user / mailing group? I can't seem to locate
> one by searching.
>
> I'm have WSDL validation errors I don't understand and I am looking for an
> appropriate list to gather some advice.
>
> Thanks.
>
> -S
>
>
Re: WSDL user group [message #181695 is a reply to message #181690] Tue, 17 October 2006 15:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: spruitt.exstream.com

Ok.

The service is document literal and it has a multipart response. A chunk of
xml and then a binary file. The relevant wsdl part looks like:

xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
:
:

<output>
<mime:multipartRelated>
<mime:part name="headers">
<soap:body use="literal"/>
</mime:part>
<mime:part name="preview">
<mime:content part="Content" type="text/binary"/>
</mime:part>
</mime:multipartRelated>
</output>

The validator is complaining about the tag- <soap:body use="literal"/>

Looking at the mime schema, it specifies children of mime:part must be
namespaced with ##targetNamespace. Don't know how to manage that. Why
require the parent tag namespace? Funny thing, searching around on the web,
I found several sites with examples like:

<mime:part name="headers">
<soap:body use="literal"/>
</mime:part>

So, I can't tell what is going on.


-S

"Valentin Baciu" <valentinbaciu@hotmail.com> wrote in message
news:eh391q$kf3$1@utils.eclipse.org...
Steve, if they are WSDL validation errors generated by the WST WSDL
validator you can post to this list.

Regards,
Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eh2v7l$kco$1@utils.eclipse.org...
> Can someone recommend a WSDL user / mailing group? I can't seem to locate
> one by searching.
>
> I'm have WSDL validation errors I don't understand and I am looking for an
> appropriate list to gather some advice.
>
> Thanks.
>
> -S
>
>
Re: WSDL user group [message #181700 is a reply to message #181695] Tue, 17 October 2006 17:37 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Steve, please post the simplest sample WSDL causing the validation error as
well as the exact wording of the validation message. Also, please don't
forget the version of WTP you are using.

We'll take it from there.
Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eh3bpo$nac$1@utils.eclipse.org...
> Ok.
>
> The service is document literal and it has a multipart response. A chunk
> of
> xml and then a binary file. The relevant wsdl part looks like:
>
> xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
> :
> :
>
> <output>
> <mime:multipartRelated>
> <mime:part name="headers">
> <soap:body use="literal"/>
> </mime:part>
> <mime:part name="preview">
> <mime:content part="Content" type="text/binary"/>
> </mime:part>
> </mime:multipartRelated>
> </output>
>
> The validator is complaining about the tag- <soap:body use="literal"/>
>
> Looking at the mime schema, it specifies children of mime:part must be
> namespaced with ##targetNamespace. Don't know how to manage that. Why
> require the parent tag namespace? Funny thing, searching around on the
> web,
> I found several sites with examples like:
>
> <mime:part name="headers">
> <soap:body use="literal"/>
> </mime:part>
>
> So, I can't tell what is going on.
>
>
> -S
>
> "Valentin Baciu" <valentinbaciu@hotmail.com> wrote in message
> news:eh391q$kf3$1@utils.eclipse.org...
> Steve, if they are WSDL validation errors generated by the WST WSDL
> validator you can post to this list.
>
> Regards,
> Valentin
>
> "Steve Pruitt" <spruitt@exstream.com> wrote in message
> news:eh2v7l$kco$1@utils.eclipse.org...
>> Can someone recommend a WSDL user / mailing group? I can't seem to
>> locate
>> one by searching.
>>
>> I'm have WSDL validation errors I don't understand and I am looking for
>> an
>> appropriate list to gather some advice.
>>
>> Thanks.
>>
>> -S
>>
>>
>
>
>
Re: WSDL user group [message #181716 is a reply to message #181700] Wed, 18 October 2006 08:23 Go to previous messageGo to next message
Eclipse User
Originally posted by: spruitt.exstream.com

Sorry, Valentin. I thought the bare minimum would be enough. The versions
are Eclipse 3.2.1 and the WTP is 1.5.1-200609230508.

The error message is:

Severity and Description Path Resource Location Creation Time Id
cvc-complex-type.2.4.a: Invalid content was found starting with element
'soap:body'. One of '{WC["http://schemas.xmlsoap.org/wsdl/mime/"]}' is
expected. EWS-WSDL/src EngineServices.wsdl line 66 1161118698302 266

and, finally the full wsdl:

<?xml version="1.0" encoding="UTF-8"?>
<definitions xmlns="http://schemas.xmlsoap.org/wsdl/"
xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
xmlns:exst="urn:beta-services" targetNamespace="urn:beta-services">
<types>
<xsd:schema>
<xsd:element name="PreviewRequest">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="PubFile" type="xsd:string" maxOccurs="1"
minOccurs="1"/>
<xsd:element name="Driver" maxOccurs="1" minOccurs="1">
<xsd:complexType>
<xsd:sequence>
<xsd:any namespace="##local" processContents="skip"
maxOccurs="unbounded" minOccurs="0"/>
</xsd:sequence>
<xsd:attribute name="filename" type="xsd:string" use="optional"
default="INPUT"/>
</xsd:complexType>
</xsd:element>
</xsd:sequence>
<xsd:attribute name="includeheader" type="xsd:boolean" use="optional"
default="false"/>
</xsd:complexType>
</xsd:element>
<xsd:element name="PreviewResponse">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="PreviewHeaders">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="Version" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="PDL" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="OutputLength" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="MessageLength" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="UserDataLength" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="PageCount" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="ReturnCode" type="xsd:integer" maxOccurs="1"
minOccurs="0"/>
<xsd:element name="FileType" type="xsd:string" maxOccurs="1"
minOccurs="0"/>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:schema>
</types>
<message name="getPreviewRequest">
<part name="Document" element="exst:PreviewRequest"/>
</message>
<message name="getPreviewResponse">
<part name="Document" element="exst:PreviewResponse"/>
<part name="Content" type="xsd:base64Binary"/>
</message>
<portType name="PreviewReportPortType">
<operation name="compose">
<input name="PreviewRequest" message="exst:getPreviewRequest"/>
<output name="PreviewResponse" message="exst:getPreviewResponse"/>
</operation>
</portType>
<binding name="PreviewReportBinding" type="exst:PreviewReportPortType">
<soap:binding transport="http://schemas.xmlsoap.org/soap/http"
style="document"/>
<operation name="compose">
<soap:operation soapAction="urn:beta-service"/>
<input>
<soap:body use="literal"/>
</input>
<output>
<mime:multipartRelated>
<mime:part name="headers">
<soap:body use="literal"/>
</mime:part>
<mime:part name="preview">
<mime:content part="Content" type="text/binary"/>
</mime:part>
</mime:multipartRelated>
</output>
</operation>
</binding>
<service name="EngineService">
<port name="EngineServicePort" binding="exst:PreviewReportBinding">
<soap:address
location="http://localhost:9080/beta/services/EngineService"/>
</port>
</service>
</definitions>
Re: WSDL user group [message #181719 is a reply to message #181716] Wed, 18 October 2006 10:12 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Thanks for the sample and details Steve - they did help me find the cause.
It appears the WSDL validator is "correct" based on the MIME binding schema
it has. Problem is that schema is wrong.

The WS-I Attachements Profile has corrected this schema. See
http://www.ws-i.org/Profiles/AttachmentsProfile-1.0.html#MIM E_Binding_Schema_Fixes


I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=161410 to track
this issue. Feel free to add yourself as CC to the bug if you have a
bugzilla account.

Regards, Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eh56bo$6rt$1@utils.eclipse.org...
> Sorry, Valentin. I thought the bare minimum would be enough. The
> versions
> are Eclipse 3.2.1 and the WTP is 1.5.1-200609230508.
>
> The error message is:
>
> Severity and Description Path Resource Location Creation Time Id
> cvc-complex-type.2.4.a: Invalid content was found starting with element
> 'soap:body'. One of '{WC["http://schemas.xmlsoap.org/wsdl/mime/"]}' is
> expected. EWS-WSDL/src EngineServices.wsdl line 66 1161118698302 266
>
> and, finally the full wsdl:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <definitions xmlns="http://schemas.xmlsoap.org/wsdl/"
> xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
> xmlns:exst="urn:beta-services" targetNamespace="urn:beta-services">
> <types>
> <xsd:schema>
> <xsd:element name="PreviewRequest">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="PubFile" type="xsd:string" maxOccurs="1"
> minOccurs="1"/>
> <xsd:element name="Driver" maxOccurs="1" minOccurs="1">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:any namespace="##local" processContents="skip"
> maxOccurs="unbounded" minOccurs="0"/>
> </xsd:sequence>
> <xsd:attribute name="filename" type="xsd:string" use="optional"
> default="INPUT"/>
> </xsd:complexType>
> </xsd:element>
> </xsd:sequence>
> <xsd:attribute name="includeheader" type="xsd:boolean" use="optional"
> default="false"/>
> </xsd:complexType>
> </xsd:element>
> <xsd:element name="PreviewResponse">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="PreviewHeaders">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="Version" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="PDL" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="OutputLength" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="MessageLength" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="UserDataLength" type="xsd:integer"
> maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="PageCount" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="ReturnCode" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="FileType" type="xsd:string" maxOccurs="1"
> minOccurs="0"/>
> </xsd:sequence>
> </xsd:complexType>
> </xsd:element>
> </xsd:sequence>
> </xsd:complexType>
> </xsd:element>
> </xsd:schema>
> </types>
> <message name="getPreviewRequest">
> <part name="Document" element="exst:PreviewRequest"/>
> </message>
> <message name="getPreviewResponse">
> <part name="Document" element="exst:PreviewResponse"/>
> <part name="Content" type="xsd:base64Binary"/>
> </message>
> <portType name="PreviewReportPortType">
> <operation name="compose">
> <input name="PreviewRequest" message="exst:getPreviewRequest"/>
> <output name="PreviewResponse" message="exst:getPreviewResponse"/>
> </operation>
> </portType>
> <binding name="PreviewReportBinding" type="exst:PreviewReportPortType">
> <soap:binding transport="http://schemas.xmlsoap.org/soap/http"
> style="document"/>
> <operation name="compose">
> <soap:operation soapAction="urn:beta-service"/>
> <input>
> <soap:body use="literal"/>
> </input>
> <output>
> <mime:multipartRelated>
> <mime:part name="headers">
> <soap:body use="literal"/>
> </mime:part>
> <mime:part name="preview">
> <mime:content part="Content" type="text/binary"/>
> </mime:part>
> </mime:multipartRelated>
> </output>
> </operation>
> </binding>
> <service name="EngineService">
> <port name="EngineServicePort" binding="exst:PreviewReportBinding">
> <soap:address
> location="http://localhost:9080/beta/services/EngineService"/>
> </port>
> </service>
> </definitions>
>
>
>
Re: WSDL user group [message #182088 is a reply to message #181719] Thu, 02 November 2006 12:59 Go to previous messageGo to next message
Eclipse User
Originally posted by: spruitt.exstream.com

Thanks for your help. I have been on the road for a bit, so I am late
getting back to you. Looking at the comments in the defect to track it, it
looks like a fix is not coming anytime soon.

I am not sure how I can resolve until a fix shows up. I look at the
validator preference properties and nothing jumped out at me. Can I
directly import the updated schema into my wsdl?


-S


"Valentin Baciu" <valentinbaciu@hotmail.com> wrote in message
news:eh5cni$imd$1@utils.eclipse.org...
Thanks for the sample and details Steve - they did help me find the cause.
It appears the WSDL validator is "correct" based on the MIME binding schema
it has. Problem is that schema is wrong.

The WS-I Attachements Profile has corrected this schema. See
http://www.ws-i.org/Profiles/AttachmentsProfile-1.0.html#MIM E_Binding_Schema_Fixes


I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=161410 to track
this issue. Feel free to add yourself as CC to the bug if you have a
bugzilla account.

Regards, Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eh56bo$6rt$1@utils.eclipse.org...
> Sorry, Valentin. I thought the bare minimum would be enough. The
> versions
> are Eclipse 3.2.1 and the WTP is 1.5.1-200609230508.
>
> The error message is:
>
> Severity and Description Path Resource Location Creation Time Id
> cvc-complex-type.2.4.a: Invalid content was found starting with element
> 'soap:body'. One of '{WC["http://schemas.xmlsoap.org/wsdl/mime/"]}' is
> expected. EWS-WSDL/src EngineServices.wsdl line 66 1161118698302 266
>
> and, finally the full wsdl:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <definitions xmlns="http://schemas.xmlsoap.org/wsdl/"
> xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
> xmlns:exst="urn:beta-services" targetNamespace="urn:beta-services">
> <types>
> <xsd:schema>
> <xsd:element name="PreviewRequest">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="PubFile" type="xsd:string" maxOccurs="1"
> minOccurs="1"/>
> <xsd:element name="Driver" maxOccurs="1" minOccurs="1">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:any namespace="##local" processContents="skip"
> maxOccurs="unbounded" minOccurs="0"/>
> </xsd:sequence>
> <xsd:attribute name="filename" type="xsd:string" use="optional"
> default="INPUT"/>
> </xsd:complexType>
> </xsd:element>
> </xsd:sequence>
> <xsd:attribute name="includeheader" type="xsd:boolean" use="optional"
> default="false"/>
> </xsd:complexType>
> </xsd:element>
> <xsd:element name="PreviewResponse">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="PreviewHeaders">
> <xsd:complexType>
> <xsd:sequence>
> <xsd:element name="Version" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="PDL" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="OutputLength" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="MessageLength" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="UserDataLength" type="xsd:integer"
> maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="PageCount" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="ReturnCode" type="xsd:integer" maxOccurs="1"
> minOccurs="0"/>
> <xsd:element name="FileType" type="xsd:string" maxOccurs="1"
> minOccurs="0"/>
> </xsd:sequence>
> </xsd:complexType>
> </xsd:element>
> </xsd:sequence>
> </xsd:complexType>
> </xsd:element>
> </xsd:schema>
> </types>
> <message name="getPreviewRequest">
> <part name="Document" element="exst:PreviewRequest"/>
> </message>
> <message name="getPreviewResponse">
> <part name="Document" element="exst:PreviewResponse"/>
> <part name="Content" type="xsd:base64Binary"/>
> </message>
> <portType name="PreviewReportPortType">
> <operation name="compose">
> <input name="PreviewRequest" message="exst:getPreviewRequest"/>
> <output name="PreviewResponse" message="exst:getPreviewResponse"/>
> </operation>
> </portType>
> <binding name="PreviewReportBinding" type="exst:PreviewReportPortType">
> <soap:binding transport="http://schemas.xmlsoap.org/soap/http"
> style="document"/>
> <operation name="compose">
> <soap:operation soapAction="urn:beta-service"/>
> <input>
> <soap:body use="literal"/>
> </input>
> <output>
> <mime:multipartRelated>
> <mime:part name="headers">
> <soap:body use="literal"/>
> </mime:part>
> <mime:part name="preview">
> <mime:content part="Content" type="text/binary"/>
> </mime:part>
> </mime:multipartRelated>
> </output>
> </operation>
> </binding>
> <service name="EngineService">
> <port name="EngineServicePort" binding="exst:PreviewReportBinding">
> <soap:address
> location="http://localhost:9080/beta/services/EngineService"/>
> </port>
> </service>
> </definitions>
>
>
>
Re: WSDL user group [message #182096 is a reply to message #182088] Thu, 02 November 2006 15:55 Go to previous message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Steve, here's a suggested workaround.

The broken MIME schema is contributed to the XML catalog by the org.wsdl4j
plug-in. You should be able to override it by specifying a user catalog
entry pointing to the new schema. So download the new schema from the URL I
mentioned below then go to Preferences/Web and XML/XML Catalog, select the
User Specified Entries and click Add. In the dialog browse to the location
where you placed the downloaded schema, specify namespace name as the key
and enter the proper namespace in the namespace field. Click OK and save the
preferences and you should be all set. Try re-validating your file: the
error should go away. I've attached a picture showing the end result of
adding the new schema to the catalog.

Valentin

"Steve Pruitt" <spruitt@exstream.com> wrote in message
news:eidblg$c2g$1@utils.eclipse.org...
> Thanks for your help. I have been on the road for a bit, so I am late
> getting back to you. Looking at the comments in the defect to track it,
> it
> looks like a fix is not coming anytime soon.
>
> I am not sure how I can resolve until a fix shows up. I look at the
> validator preference properties and nothing jumped out at me. Can I
> directly import the updated schema into my wsdl?
>
>
> -S
>
>
> "Valentin Baciu" <valentinbaciu@hotmail.com> wrote in message
> news:eh5cni$imd$1@utils.eclipse.org...
> Thanks for the sample and details Steve - they did help me find the cause.
> It appears the WSDL validator is "correct" based on the MIME binding
> schema
> it has. Problem is that schema is wrong.
>
> The WS-I Attachements Profile has corrected this schema. See
> http://www.ws-i.org/Profiles/AttachmentsProfile-1.0.html#MIM E_Binding_Schema_Fixes
>
>
> I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=161410 to track
> this issue. Feel free to add yourself as CC to the bug if you have a
> bugzilla account.
>
> Regards, Valentin
>
> "Steve Pruitt" <spruitt@exstream.com> wrote in message
> news:eh56bo$6rt$1@utils.eclipse.org...
>> Sorry, Valentin. I thought the bare minimum would be enough. The
>> versions
>> are Eclipse 3.2.1 and the WTP is 1.5.1-200609230508.
>>
>> The error message is:
>>
>> Severity and Description Path Resource Location Creation Time Id
>> cvc-complex-type.2.4.a: Invalid content was found starting with element
>> 'soap:body'. One of '{WC["http://schemas.xmlsoap.org/wsdl/mime/"]}' is
>> expected. EWS-WSDL/src EngineServices.wsdl line 66 1161118698302 266
>>
>> and, finally the full wsdl:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <definitions xmlns="http://schemas.xmlsoap.org/wsdl/"
>> xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
>> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
>> xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
>> xmlns:exst="urn:beta-services" targetNamespace="urn:beta-services">
>> <types>
>> <xsd:schema>
>> <xsd:element name="PreviewRequest">
>> <xsd:complexType>
>> <xsd:sequence>
>> <xsd:element name="PubFile" type="xsd:string" maxOccurs="1"
>> minOccurs="1"/>
>> <xsd:element name="Driver" maxOccurs="1" minOccurs="1">
>> <xsd:complexType>
>> <xsd:sequence>
>> <xsd:any namespace="##local" processContents="skip"
>> maxOccurs="unbounded" minOccurs="0"/>
>> </xsd:sequence>
>> <xsd:attribute name="filename" type="xsd:string"
>> use="optional"
>> default="INPUT"/>
>> </xsd:complexType>
>> </xsd:element>
>> </xsd:sequence>
>> <xsd:attribute name="includeheader" type="xsd:boolean" use="optional"
>> default="false"/>
>> </xsd:complexType>
>> </xsd:element>
>> <xsd:element name="PreviewResponse">
>> <xsd:complexType>
>> <xsd:sequence>
>> <xsd:element name="PreviewHeaders">
>> <xsd:complexType>
>> <xsd:sequence>
>> <xsd:element name="Version" type="xsd:integer" maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="PDL" type="xsd:integer" maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="OutputLength" type="xsd:integer" maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="MessageLength" type="xsd:integer"
>> maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="UserDataLength" type="xsd:integer"
>> maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="PageCount" type="xsd:integer" maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="ReturnCode" type="xsd:integer" maxOccurs="1"
>> minOccurs="0"/>
>> <xsd:element name="FileType" type="xsd:string" maxOccurs="1"
>> minOccurs="0"/>
>> </xsd:sequence>
>> </xsd:complexType>
>> </xsd:element>
>> </xsd:sequence>
>> </xsd:complexType>
>> </xsd:element>
>> </xsd:schema>
>> </types>
>> <message name="getPreviewRequest">
>> <part name="Document" element="exst:PreviewRequest"/>
>> </message>
>> <message name="getPreviewResponse">
>> <part name="Document" element="exst:PreviewResponse"/>
>> <part name="Content" type="xsd:base64Binary"/>
>> </message>
>> <portType name="PreviewReportPortType">
>> <operation name="compose">
>> <input name="PreviewRequest" message="exst:getPreviewRequest"/>
>> <output name="PreviewResponse" message="exst:getPreviewResponse"/>
>> </operation>
>> </portType>
>> <binding name="PreviewReportBinding" type="exst:PreviewReportPortType">
>> <soap:binding transport="http://schemas.xmlsoap.org/soap/http"
>> style="document"/>
>> <operation name="compose">
>> <soap:operation soapAction="urn:beta-service"/>
>> <input>
>> <soap:body use="literal"/>
>> </input>
>> <output>
>> <mime:multipartRelated>
>> <mime:part name="headers">
>> <soap:body use="literal"/>
>> </mime:part>
>> <mime:part name="preview">
>> <mime:content part="Content" type="text/binary"/>
>> </mime:part>
>> </mime:multipartRelated>
>> </output>
>> </operation>
>> </binding>
>> <service name="EngineService">
>> <port name="EngineServicePort" binding="exst:PreviewReportBinding">
>> <soap:address
>> location="http://localhost:9080/beta/services/EngineService"/>
>> </port>
>> </service>
>> </definitions>
>>
>>
>>
>
>
>


  • Attachment: pic.JPG
    (Size: 53.30KB, Downloaded 45 times)
Previous Topic:Remote web server setup problem
Next Topic:Want to learn more about WTP?
Goto Forum:
  


Current Time: Fri Jul 25 11:19:57 EDT 2014

Powered by FUDForum. Page generated in 0.13660 seconds