Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WebTools 2.0M2 missing dependencies??
WebTools 2.0M2 missing dependencies?? [message #181130] Sun, 08 October 2006 12:51 Go to next message
Frits Jalvingh is currently offline Frits JalvinghFriend
Messages: 19
Registered: July 2009
Junior Member
Hi,
I just tried to use WTP 2.0m2 using the complete set as specified on the
download page (eclipse 3.3m2 enz). But when I try to add a feature using
the Update Manager I get errors stating that a lot of internal plugin
dependencies are not OK:

The current configuration contains errors and this operation can have
unpredictable results.
WST XML Core (1.6.0.v200609120056--3YIAAYAjHMDXHW) requires feature
"org.eclipse.rcp (3.2.0)", or equivalent.
WST Relational Database Core (1.5.1.v200608082043--3YIAAYAhEOHKEP)
requires feature "org.eclipse.platform (3.2.0)", or equivalent.
WST Web Core (1.5.1.v200608082043--4hNDDhDtMTHeIN) requires feature
"org.eclipse.platform (3.2.0)", or equivalent.
JST Enterprise Core (1.5.1.v200608082043--2PD88P8YAVD8JG) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
WST Relational Database Adapters
(1.5.1.v200608082043--Cq0bcpdMx4piv_) requires feature
"org.eclipse.platform (3.2.0)", or equivalent.
JST Enterprise UI (1.5.1.v200608082043-pEBq_jDGdFuyHoX) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
JST Common Core (1.5.1.v200608082043--0842282_363738) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
JST Server Core (1.5.1.v200608082043--2PD88P9LBK778A) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
WST Web Services Core (1.5.1.v200608082043--4hNDDhDvGZLWQW) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
JST Web Core (1.5.1.v200608082043--87cMN7P_S_XKki) requires feature
"org.eclipse.platform (3.2.0)", or equivalent.
WST Server Core (1.5.1.v200608082043------1G955G6C5J) requires
feature "org.eclipse.rcp (3.2.0)", or equivalent.

Anyone knows what causes this? It seems like the M2 build is wrong. As
was the M1 build which exhibits the same behaviour.
Re: WebTools 2.0M2 missing dependencies?? [message #181138 is a reply to message #181130] Sun, 08 October 2006 14:24 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Sun, 08 Oct 2006 08:51:56 -0400, Frits Jalvingh <jal@etc.to> wrote:

> Hi,
> I just tried to use WTP 2.0m2 using the complete set as specified on t=
he =

> download page (eclipse 3.3m2 enz). But when I try to add a feature usi=
ng =

> the Update Manager I get errors stating that a lot of internal plugin =
=

> dependencies are not OK:
>

Thanks for the reminder. We have not yet updated our features to spec th=
e
correct pre-req features yet. Everything should run fine, if you just =

unzip the
zip files, since the plugins are fine. We need to ether update those
out-of-date feature specs, or remove them.

I've updated bug 154979 to track this for M3.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D154979
Re: WebTools 2.0M2 missing dependencies?? [message #182946 is a reply to message #181138] Mon, 20 November 2006 10:47 Go to previous message
Johannes Weberhofer is currently offline Johannes WeberhoferFriend
Messages: 15
Registered: July 2009
Junior Member
Unfortunately this issue is still open. This makes testing very complicated, becuse after the installation of WT 2.0 M2 or M3 the Update Manager and the installation of can no longer be used.

Best regards,
Johannes Weberhofer

David Williams schrieb:
> On Sun, 08 Oct 2006 08:51:56 -0400, Frits Jalvingh <jal@etc.to> wrote:
>
>> Hi,
>> I just tried to use WTP 2.0m2 using the complete set as specified on
>> the download page (eclipse 3.3m2 enz). But when I try to add a feature
>> using the Update Manager I get errors stating that a lot of internal
>> plugin dependencies are not OK:
>>
>
> Thanks for the reminder. We have not yet updated our features to spec the
> correct pre-req features yet. Everything should run fine, if you just
> unzip the
> zip files, since the plugins are fine. We need to ether update those
> out-of-date feature specs, or remove them.
>
> I've updated bug 154979 to track this for M3.
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=154979
Previous Topic:Question about AddRemoveProjects action?
Next Topic:jsp error: package does not exist
Goto Forum:
  


Current Time: Thu Dec 18 10:46:50 GMT 2014

Powered by FUDForum. Page generated in 0.03436 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software