Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Error exporting an Eclipse product with Kepler 3.4.1
Error exporting an Eclipse product with Kepler 3.4.1 [message #1158048] Sun, 27 October 2013 17:22 Go to next message
Marc Gil is currently offline Marc Gil
Messages: 189
Registered: July 2009
Location: Valencia, Spain
Senior Member
Hello,

I'm trying to export an Eclipse product, and I'm having always the same error:
java.lang.StackOverflowError
	at java.util.HashMap.getEntry(Unknown Source)
	at java.util.HashMap.get(Unknown Source)
	at org.eclipse.pde.internal.core.FeatureTable.getImpl(FeatureTable.java:109)
	at org.eclipse.pde.internal.core.FeatureTable.get(FeatureTable.java:101)
	at org.eclipse.pde.internal.core.FeatureModelManager.findFeatureModel(FeatureModelManager.java:145)
	at org.eclipse.pde.internal.core.feature.FeatureChild.getReferencedFeature(FeatureChild.java:131)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:353)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:355)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:355)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:355)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:355)
	at org.eclipse.pde.internal.core.exports.FeatureExportOperation.deleteBuildFiles(FeatureExportOperation.java:355)


And so on...

And don't really know why this error is being thrown. I can launch the product as a second instance of Eclipse and all works fine, but when exporting it, this error appears.

Any idea? Thanks..

Marc
Re: Error exporting an Eclipse product with Kepler 3.4.1 [message #1158142 is a reply to message #1158048] Sun, 27 October 2013 18:52 Go to previous message
Marc Gil is currently offline Marc Gil
Messages: 189
Registered: July 2009
Location: Valencia, Spain
Senior Member
It seems to be an error with some features of gmf and xpand that were included in the product, and contains some plugins that can't be loaded by Eclipse Kepler 4.3.1... Removing these features (seems to be unuseful to me) solved the problem (I needed to debug the whole Eclipse from another Eclipse instance... this is nuts...)

Marc
Previous Topic:Looking for platform releng basebuilder for Eclipse Kepler 4.3.1
Next Topic:Key Problem in Eclipse - It asks for confirmation
Goto Forum:
  


Current Time: Wed Sep 17 15:43:28 GMT 2014

Powered by FUDForum. Page generated in 0.02632 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software