Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Web features missing despite WST/JST
Web features missing despite WST/JST [message #180496] Wed, 04 October 2006 09:01 Go to next message
Eclipse User
Originally posted by: simon.niederberger.want.ch

Hi

I've just installed Eclipse 3.2.1 with the features listed below. However, I
have several issues which - I'm guessing - all come from some installation
glitch in the JST/WST.

Eclipse SDK 3.2.1.r321
EMF SDO 2.2.0
GEF 3.2.0
JST SDK 1.5.1
Java EMF SDK 1.2.1
WST SDK 1.5.1
XSD Schema Infoset 2.2.1

From the project pages on eclipse.org, I feel I have everything I need, but:

1) From File => New, there is no "Web" node, therefore no new JSP, no new
Dynamic Web Project etc
2) The project facets jst.java and jst.web are not implemented (using a
project from an older Eclipse installation)
3) No tab group defined for launch configuration type
org.eclipse.jst.server.tomcat.core.launchConfigurationType

Thanks for any help (even a RTFM if a link is provided)
Simon
Re: Web features missing despite WST/JST [message #180531 is a reply to message #180496] Wed, 04 October 2006 12:24 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 690
Registered: July 2009
Senior Member
>
> Eclipse SDK 3.2.1.r321
> EMF SDO 2.2.0
> GEF 3.2.0
> JST SDK 1.5.1
> Java EMF SDK 1.2.1
> WST SDK 1.5.1
> XSD Schema Infoset 2.2.1
>

Those all sound right. GEF should also be at 3.2.1, but would be surprised
that could cause what you are seeing. (And, just to confirm, that is the
full Eclipse SDK, right? Not the smaller "platform" sdk?). And, installed
in a fresh directory, right?

You might check the log, to see the first thing it detects that is
missing ... there would be some messages like "missing constraint ... "

Or, you might try one of the "all in once" zip packages at
http://download.eclipse.org/webtools/downloads/drops/R1.5/R- 1.5.1-200609230508/
see if that works, and assuming so, compare the file directories to narrow
down what you're missing.

Let us know if you find some specific problem.
Re: Web features missing despite WST/JST [message #180585 is a reply to message #180531] Thu, 05 October 2006 02:04 Go to previous message
Eclipse User
Originally posted by: simon.niederberger.want.ch

Hi David

Thanks for the feedback. I'd originally wanted to switch from 3.1.2 to
Eclipse 3.2.1 because of the TPTP, but later found that there are TPTP
versions around for Eclipse 3.1.2. So I temporarily gave up on the setup and
switched back to Eclipse 3.1.2.

Nevertheless, thanks for the "all-in-one" link, I missed that one. Will try
that out asap. As I've deleted all 3.2.1 installations, I don't have any log
files anymore. But if I find something, I'll post it here.

Thanks
Simon

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.tgwnu3nwac05ss@dmw2t23.ibm.com...
> >
>> Eclipse SDK 3.2.1.r321
>> EMF SDO 2.2.0
>> GEF 3.2.0
>> JST SDK 1.5.1
>> Java EMF SDK 1.2.1
>> WST SDK 1.5.1
>> XSD Schema Infoset 2.2.1
>>
>
> Those all sound right. GEF should also be at 3.2.1, but would be surprised
> that could cause what you are seeing. (And, just to confirm, that is the
> full Eclipse SDK, right? Not the smaller "platform" sdk?). And, installed
> in a fresh directory, right?
>
> You might check the log, to see the first thing it detects that is
> missing ... there would be some messages like "missing constraint ... "
>
> Or, you might try one of the "all in once" zip packages at
> http://download.eclipse.org/webtools/downloads/drops/R1.5/R- 1.5.1-200609230508/
> see if that works, and assuming so, compare the file directories to narrow
> down what you're missing.
>
> Let us know if you find some specific problem.
Previous Topic:change logging levels of WTP in Eclipse console
Next Topic:EMF EditModel Extension
Goto Forum:
  


Current Time: Wed Apr 16 20:53:22 EDT 2014

Powered by FUDForum. Page generated in 0.01616 seconds