Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Problem with Project Facet
Problem with Project Facet [message #179520] Thu, 21 September 2006 06:03 Go to next message
Alan Chandler is currently offline Alan Chandler
Messages: 45
Registered: July 2009
Member
It has been a couple of months since I last used Eclipse and I am on a
sharp learning curve. I am trying to fix a bug that has appeared in
one of my dynamic web applications. But I can't even get off first
base.

When I import my project back into Eclipse, I get the following error
shown in the project

"Java compiler level does not match the version of the installed Java
project facet."

My Java compiler level is set at 5.0 because I need the facilities at
this level. The java project facet says it is version 1.4

But - I don't even understand what a project facet is and where it comes
from, nor how to change the version from anything other than 1.4. If I
try to deselect this facet a dialog box pops up and says I can't.

I know in the past this application built under Eclipse just fine. But
since that time I have removed Eclipse, and later re-installed it from
a fresh download. I think "project facets" as a property of a project
has appeared during this down period, but I could not be certain of
that. I just don't remember them from before.

Can someone please explain what a project facet is, and how to set it up
so that I can use the correct java version.

TIA
Re: Problem with Project Facet [message #179541 is a reply to message #179520] Thu, 21 September 2006 12:42 Go to previous messageGo to next message
Eclipse User
Originally posted by: kosta.bea.com

Alan,

Facets are just a standard way of describing what facilities are
available on a project. It sounds from your e-mail that you found the
Project Facets properties page where you were trying to deselect the
Java facet and couldn't do it. No, you cannot deselect the Java facet as
doing that would remove the Java support from the project, but you can
change the version from 1.4 to 5.0 by clicking in the version field.
Alternatively, you can do this directly from the problems view by
utilizing the quick-fixes provided for the problem that you described.

Hope this helps to clarify and welcome back to WTP!

- Konstantin
Re: Problem with Project Facet [message #179565 is a reply to message #179541] Thu, 21 September 2006 18:20 Go to previous message
Alan Chandler is currently offline Alan Chandler
Messages: 45
Registered: July 2009
Member
Konstantin Komissarchik wrote:

> Alan,
>
> Facets are just a standard way of describing what facilities are
> available on a project. It sounds from your e-mail that you found the
> Project Facets properties page where you were trying to deselect the
> Java facet and couldn't do it. No, you cannot deselect the Java facet
> as doing that would remove the Java support from the project, but you
> can change the version from 1.4 to 5.0 by clicking in the version
> field. Alternatively, you can do this directly from the problems view
> by utilizing the quick-fixes provided for the problem that you
> described.
>

Doh - that was simple. I guess my brain was riddled last night/this
morning when I tried to fix it. Too many late nights/early mornings
this week!

Thanks
Previous Topic:Am I missing Something ???????
Next Topic:Tomcat 5.5 - 404 errors when running in Eclipse
Goto Forum:
  


Current Time: Thu Oct 23 16:36:11 GMT 2014

Powered by FUDForum. Page generated in 0.14626 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software