Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installing fails(Items cannot be found)
Installing fails [message #1152683] Thu, 24 October 2013 05:39 Go to next message
Tomas Sandkvist is currently offline Tomas SandkvistFriend
Messages: 108
Registered: October 2013
Senior Member
After my previous post regarding errors in profile I decided to dump Topcased and go for a clean eclipse and Papyrus installation.

I have followed the instructions at the Papyrus site, and choosen http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/kepler as the download site as stated there.

However, there is no installation done. I get the following errors

Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus SDK Binaries and sources (Incubation) 0.10.0.v201306121352 (org.eclipse.papyrus.sdk.sources.feature.feature.group 0.10.0.v201306121352)
Missing requirement: EMF Tools (Incubation) 0.10.0.v201306121352 (org.eclipse.papyrus.infra.emf 0.10.0.v201306121352) requires 'bundle org.eclipse.gmf.runtime.common.core 1.7.0' but it could not be found
Cannot satisfy dependency:
From: Papyrus Infra EMF (Incubation) 0.10.0.v201306121352 (org.eclipse.papyrus.infra.emf.feature.feature.group 0.10.0.v201306121352)
To: org.eclipse.papyrus.infra.emf [0.10.0.v201306121352]
Cannot satisfy dependency:
From: Papyrus UML (Incubation) 0.10.0.v201306121352 (org.eclipse.papyrus.sdk.feature.feature.group 0.10.0.v201306121352)
To: org.eclipse.papyrus.infra.emf.feature.feature.group [0.10.0.v201306121352]
Cannot satisfy dependency:
From: Papyrus SDK Binaries and sources (Incubation) 0.10.0.v201306121352 (org.eclipse.papyrus.sdk.sources.feature.feature.group 0.10.0.v201306121352)
To: org.eclipse.papyrus.sdk.feature.feature.group [0.10.0.v201306121352]

I'm at an office site with firewalls and stuff could this matter (Networking in Eclipse seems setup properly using the correct proxy)?

Regards,
Tomas Sandkvist
Sweden

(EDIT: Well, it seems as if the Eclipse version referenced from the Papyrus site is the Juno version and not the Kepler version with might be the culprit. I'm now downloading Kepler and will make a new try)

EDIT II: YES!! Now it works! A small tip to the people who runs the website - point us newbies in the right direction by updating the links... ;-

[Updated on: Thu, 24 October 2013 06:29]

Report message to a moderator

Re: Installing fails [message #1152767 is a reply to message #1152683] Thu, 24 October 2013 06:51 Go to previous messageGo to next message
Logan M is currently offline Logan MFriend
Messages: 8
Registered: October 2013
Location: Toulouse
Junior Member
The prefered way is to install the "Extra Modeling Components Installer" from default Eclipse installation site (ex: http://download.eclipse.org/releases/kepler/)
Re: Installing fails [message #1153085 is a reply to message #1152767] Thu, 24 October 2013 11:18 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 500
Registered: February 2011
Senior Member
Hi,

I have updated the Installation Guide to use the correct versions of each component.

Regards,
Camille


Camille Letavernier
Papyrus developer
Previous Topic:No call behavior action in activity diagram?
Next Topic:UML model to SysML model
Goto Forum:
  


Current Time: Fri Nov 21 12:13:51 GMT 2014

Powered by FUDForum. Page generated in 0.02502 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software