Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Detached view freeze until resized(One of the shells stop responding (mouse down, redraw, tooltip, button hover, etc) unexpectedly and resumes normal after shell begin resized)
Detached view freeze until resized [message #1152579] Thu, 24 October 2013 04:04
Leung Wang Hei is currently offline Leung Wang Hei
Messages: 62
Registered: July 2010
Member
I know this is weird and not sure if it is a SWT or RCP issues.

My RCP is running on Win 7, java 1.6, RCP 3.7.

Quite randomly, one the the detached views (one view in the shell, no stacking) just stopped responding to all user actions, click, mouse hover, data update redraw gave no visual respond.

Even the view action menu buttons gave no hover effect and mouse-down response.

I am able to move the shell and the same content (rather then any updated data) displayed.

Clicking the "x" at the view title tab closes the view (and the shell as there is only one view).

With the freezing view still there, other detached views of the same app worked fine. Buttons, redraw, hovering all worked fine.

Once the problematic shell being re-sized, everything back to normal.


-----------

This issue is completely random and so sorry that I cannot provide a sample code here.

Google-ing and blind testing for weeks, no luck so far.

Any idea or hints are greatly appreciated.




Previous Topic:SWT browser widget, Webkit and Java applets on Linux
Next Topic:Multi Line RadioButton and Checkbox
Goto Forum:
  


Current Time: Sun Oct 26 07:49:05 GMT 2014

Powered by FUDForum. Page generated in 0.01952 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software