Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » "Java compiler level does not match the version of the installed Java project facet"
"Java compiler level does not match the version of the installed Java project facet" [message #178931] Mon, 11 September 2006 19:34 Go to next message
Eclipse UserFriend
Originally posted by: andre.fatecsp.ig.com.br

Hi,

why i keep on getting this problem message when I set my web or ejb 3.0
projects for Java 5.0 compliance? With Java 6.0 it doesn't happen!!!

Thanks.
Re: "Java compiler level does not match the version of the installed Java project facet" [message #178942 is a reply to message #178931] Mon, 11 September 2006 20:05 Go to previous message
Eclipse UserFriend
Originally posted by: kosta.bea.com

A wtp project is composed of multiple units of functionality (known as
facets). Take a look at Project Properties -> Project Facets panel. The
java facet version needs to always match the java compiler compliance
level. The best way to change java level is to use the Project Facets
properties panel as that will update both places at the same time.
Alternatively, when you get the error that you are referring to, there
are quick fixes available to resolve it.

- Konstantin
Previous Topic:WTP 2.0
Next Topic:WTP Best Practices?
Goto Forum:
  


Current Time: Sat Dec 20 05:25:33 GMT 2014

Powered by FUDForum. Page generated in 2.06596 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software