Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Koneki » Koneki LDT stops after stepping twice
Koneki LDT stops after stepping twice [message #1149140] Mon, 21 October 2013 20:18 Go to next message
A J is currently offline A J
Messages: 3
Registered: October 2013
Junior Member
Hi,

I am trying to run Koneki LDT with Eclipse to attach debug a lua project. I start the LDT debug server in Eclipse and run the project itself on cmd prompt.
Some information about my setup:
1. I have Socket and Mime libraries in "C:\Program Files (x86)\Lua\5.1\clibs" and mime.lua,socket.lua,url.lua in "C:\Program Files (x86)\Lua\5.1\lua". I have set these paths in LUA_PATH and LUA_CPATH environmental variables.

2. Also, I have:
package.cpath=package.cpath .. "C:/Program Files (x86)/Lua/5.1/clibs/?.dll;"
package.path = package.path .. ";C:/Program Files (x86)/Lua/5.1/lua/?.lua"

3. require(socket.core) and require(mime.core) in the lua files do nto work for me so I included
socketcore = package.loadlib("C://Program Files (x86)//Lua//5.1//clibs//socket//core.dll","luaopen_socket_core")()
mime = package.loadlib("C://Program Files (x86)//Lua//5.1//clibs//mime//core.dll","luaopen_mime_core")()
in my lua script at the beginning, so that these libraries are loaded before I start using them.
4. I am using Version: Juno Service Release 2

5. I have the require debugger line in my lua file and have verified the configurations to match between server and the lua file.

Given the above information, I notice that when I start my project, it goes through and hits the first line after the require debugger line in my script as expected. I am able to step (into/over) 2 times. The second time I do either, debug server stops. I do not see any logs to indicate what is going on either in eclipse or cmd prompt where I am running my project (client side).

As a note, if I copy over the libraries and files into my project, everything works fine. This makes me think that it might be the visibility to the libraries or files but not sure what I can do other than setting env variables and package.path/cpath. Any inputs are welcome.

Thanks
Re: Koneki LDT stops after stepping twice [message #1151762 is a reply to message #1149140] Wed, 23 October 2013 11:31 Go to previous message
Simon Bernard is currently offline Simon Bernard
Messages: 154
Registered: July 2009
Senior Member
Hi A.J,

You say require(socket.core) and require(mime.core) does not work for you, but the debugger needs to access to lua socket with "require". So that should not help, even if the symptom seem's not linked to that ... :/
No log, works fine 2 times ... it's hard to do a good diagnostic Wink
You could enable DBGP logging (check box in launch configuration) and view logs in "Script Debug Log" view, but not sure this will help :/
Previous Topic:LDT build failure
Next Topic:Vendor specific debug protocol commands
Goto Forum:
  


Current Time: Mon Apr 21 05:40:37 EDT 2014

Powered by FUDForum. Page generated in 0.01848 seconds