Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » error while build ejb with xdoclet
error while build ejb with xdoclet [message #176348] Mon, 07 August 2006 01:05 Go to next message
rain is currently offline rainFriend
Messages: 1
Registered: July 2009
Junior Member
I created a ejb project, and make a linked source folder in my project. My
ejb source code is in this folder. When I run xdoclet to compile my project,
the xdoclet can not find my linked source folder:


Buildfile:
H:\workspace\.metadata\.plugins\org.eclipse.jst.j2ee.ejb.ann otations.xdoclet\tempAnt.xml
init:
ejbdoclet:
[ejbdoclet] H:\workspace\Test\src not found.
[ejbdoclet] at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScann er(AbstractFileSet.java:349)
[ejbdoclet] at xjavadoc.ant.XJavadocTask.execute(XJavadocTask.java:98)
[ejbdoclet] at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.j ava:275)
[ejbdoclet] at org.apache.tools.ant.Task.perform(Task.java:364)
[ejbdoclet] at org.apache.tools.ant.Target.execute(Target.java:341)
[ejbdoclet] at org.apache.tools.ant.Target.performTasks(Target.java:369)
[ejbdoclet] at
org.apache.tools.ant.Project.executeSortedTargets(Project.ja va:1216)
[ejbdoclet] at org.apache.tools.ant.Project.executeTarget(Project.java:1185 )
[ejbdoclet] at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(D efaultExecutor.java:40)
[ejbdoclet] at
org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecuto r.executeTargets(EclipseDefaultExecutor.java:32)
[ejbdoclet] at
org.apache.tools.ant.Project.executeTargets(Project.java:106 8)
[ejbdoclet] at
org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run (InternalAntRunner.java:423)
[ejbdoclet] at
org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.mai n(InternalAntRunner.java:137)

BUILD FAILED
H:\workspace\.metadata\.plugins\org.eclipse.jst.j2ee.ejb.ann otations.xdoclet\tempAnt.xml:69:
Unexpected error

Total time: 3 seconds


I think it is a bug of the eclipse xdoclet plugin.
Re: error while build ejb with xdoclet [message #722335 is a reply to message #176348] Mon, 05 September 2011 12:12 Go to previous message
Govind  is currently offline Govind Friend
Messages: 1
Registered: September 2011
Junior Member
I also got the same problem.
Do you find solution for this Bug in the mean while?
I search it out but not able to get readout of this problem.
Previous Topic:eclipse gui disappear
Next Topic:Adding New Servers types error: Executable commandline is unspecified
Goto Forum:
  


Current Time: Fri Nov 28 15:04:09 GMT 2014

Powered by FUDForum. Page generated in 0.01643 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software