Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » eclipse.ini not working(I am exporting e(fx)clipse 0.9.0 application, but when i am launching the apllication , it was able to read information from eclipse.ini file)
eclipse.ini not working [message #1140481] Wed, 16 October 2013 11:37 Go to next message
Vivek Bajpai is currently offline Vivek BajpaiFriend
Messages: 7
Registered: October 2013
Location: Pune, India
Junior Member

Hi

I am trying build e4 application with JavaFX 8 with e(fx)clipse 0.9.0.
Every thing is fine but when i had exported the application created with maven and ant,
the exported application is not loading the information from eclipse.ini file.
I need information like

-Djava.library.path
-clearPersistState


So please any body can help me regarding this issue.

Re: eclipse.ini not working [message #1140578 is a reply to message #1140481] Wed, 16 October 2013 13:02 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5469
Registered: July 2009
Senior Member
The eclipse.ini is only read when launched through the eclipse.exe, the
clearPersistedState could be set directly in the plugin.xml.

To pass information to the JVM launched through the generated
(fx)launcher you can use the following elements in the build.xml:

> http://docs.oracle.com/javafx/2/deployment/javafx_ant_task_reference.htm#CIAHCIFJ
> http://docs.oracle.com/javafx/2/deployment/javafx_ant_task_reference.htm#CIAHJIJG

Tom

On 16.10.13 14:48, Vivek Bajpai wrote:
> Hi
>
> I am trying build e4 application with JavaFX 8 with e(fx)clipse 0.9.0.
> Every thing is fine but when i had exported the application created with
> maven and ant,
> the exported application is not loading the information from eclipse.ini
> file.
> I need information like
> -Djava.library.path
> -clearPersistState
>
>
> So please any body can help me regarding this issue.
>
>
Re: eclipse.ini not working [message #1141890 is a reply to message #1140578] Thu, 17 October 2013 08:58 Go to previous messageGo to next message
Vivek Bajpai is currently offline Vivek BajpaiFriend
Messages: 7
Registered: October 2013
Location: Pune, India
Junior Member

Hi Thomas

I got the solution for clearPersistedState , by setting this into plugin.xml file.

but not able set java.libary.path with ant.

I am trying with below code

<fx:deploy
embedJNLP="false"
extension="false"
includeDT="false"
offlineAllowed="true"
outdir="${basedir}/deploy"
outfile="fix-ide"
nativeBundles="all"
updatemode="background"
>

<fx:info title="DPWorkbench" vendor="Ventana Medical System"/>
<fx:application refid="fxApplication"/>
<fx:resources refid="appRes"/>
<fx:platform>
<fx:property name="-Djava.libary.path" value="${user.dir}/dlls"/>
</fx:platform>
</fx:deploy>

Please help me.
Re: eclipse.ini not working [message #1141891 is a reply to message #1140578] Thu, 17 October 2013 08:59 Go to previous messageGo to next message
Vivek Bajpai is currently offline Vivek BajpaiFriend
Messages: 7
Registered: October 2013
Location: Pune, India
Junior Member

No Message Body
Re: eclipse.ini not working [message #1141899 is a reply to message #1140578] Thu, 17 October 2013 09:05 Go to previous messageGo to next message
Vivek Bajpai is currently offline Vivek BajpaiFriend
Messages: 7
Registered: October 2013
Location: Pune, India
Junior Member

Hi

I am not able to set java.library.path with (fx)launcher
trying this

<fx:deploy
embedJNLP="false"
extension="false"
includeDT="false"
offlineAllowed="true"
outdir="${basedir}/deploy"
outfile="fix-ide"
nativeBundles="all"
updatemode="background"
>

<fx:info title="DPWorkbench" vendor="Ventana Medical System"/>
<fx:application refid="fxApplication"/>
<fx:resources refid="appRes"/>
<fx:platform>
<fx:property name="-Djava.libary.path" value="${user.dir}/dlls"/>
</fx:platform>
</fx:deploy>

please help me
Re: eclipse.ini not working [message #1141969 is a reply to message #1141899] Thu, 17 October 2013 09:59 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5469
Registered: July 2009
Senior Member
On 17.10.13 11:05, Vivek Bajpai wrote:
> Hi
>
> I am not able to set java.library.path with (fx)launcher
> trying this
>
> <fx:deploy
> embedJNLP="false"
> extension="false"
> includeDT="false"
> offlineAllowed="true"
> outdir="${basedir}/deploy"
> outfile="fix-ide" nativeBundles="all"
> updatemode="background"
> >
>
> <fx:info title="DPWorkbench" vendor="Ventana Medical System"/>
> <fx:application refid="fxApplication"/>
> <fx:resources refid="appRes"/>
> <fx:platform>
> <fx:property name="-Djava.libary.path"
> value="${user.dir}/dlls"/>
> </fx:platform>
> </fx:deploy>
>
> please help me

Are you sure you put the -D there? Doesn't fx:property imply -D? You
better ask at a JavaFX forum, I'm NOT a specialist on this stuff.

Tom
Previous Topic:Model Processing and Rendering Window children of a Window
Next Topic:JavaFX - Jemmy
Goto Forum:
  


Current Time: Fri Nov 28 06:16:42 GMT 2014

Powered by FUDForum. Page generated in 0.10562 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software