Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » CTabItem background-color not themable?
CTabItem background-color not themable? [message #1139432] Tue, 15 October 2013 19:21 Go to next message
Andrej Dimic is currently offline Andrej Dimic
Messages: 73
Registered: July 2009
Member
Hi

we tried to change the background color of CTabItems with Themeing.

CTabItem {
font: 14px Verdana, "Lucida Sans", Arial, Helvetica, sans-serif;
color: #4a4a4a;
background-color: #cccccc;
background-image: none;
padding: 6px 15px;
spacing: 10px;
text-shadow: none;
}

this seems to have no effect. we tried with RAP 2.1 and RAP 2.2 M2.

Any Ideas (besides CTabFolder.setBackground(Color) ?

Thanks
Andrej
Re: CTabItem background-color not themable? [message #1141580 is a reply to message #1139432] Thu, 17 October 2013 04:35 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
Hi Andrej,
I can confirm the problem with Controls Demo and default theme. Please
open a bugzilla and we will look on it.
Thanks,
Ivan

On 10/15/2013 10:21 PM, Andrej Dimic wrote:
> Hi
>
> we tried to change the background color of CTabItems with Themeing.
>
> CTabItem {
> font: 14px Verdana, "Lucida Sans", Arial, Helvetica, sans-serif;
> color: #4a4a4a;
> background-color: #cccccc;
> background-image: none;
> padding: 6px 15px;
> spacing: 10px;
> text-shadow: none;
> }
>
> this seems to have no effect. we tried with RAP 2.1 and RAP 2.2 M2.
>
> Any Ideas (besides CTabFolder.setBackground(Color) ?
>
> Thanks
> Andrej
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: CTabItem background-color not themable? [message #1141699 is a reply to message #1139432] Thu, 17 October 2013 06:22 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
I've opened a bug:
419657: [CTabFolder] CTabItem background color set by theming is not
respected
https://bugs.eclipse.org/bugs/show_bug.cgi?id=419657

On 10/15/2013 10:21 PM, Andrej Dimic wrote:
> Hi
>
> we tried to change the background color of CTabItems with Themeing.
>
> CTabItem {
> font: 14px Verdana, "Lucida Sans", Arial, Helvetica, sans-serif;
> color: #4a4a4a;
> background-color: #cccccc;
> background-image: none;
> padding: 6px 15px;
> spacing: 10px;
> text-shadow: none;
> }
>
> this seems to have no effect. we tried with RAP 2.1 and RAP 2.2 M2.
>
> Any Ideas (besides CTabFolder.setBackground(Color) ?
>
> Thanks
> Andrej
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: CTabItem background-color not themable? [message #1141714 is a reply to message #1139432] Thu, 17 October 2013 06:30 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
The issue is fixed in RAP master.

On 10/15/2013 10:21 PM, Andrej Dimic wrote:
> Hi
>
> we tried to change the background color of CTabItems with Themeing.
>
> CTabItem {
> font: 14px Verdana, "Lucida Sans", Arial, Helvetica, sans-serif;
> color: #4a4a4a;
> background-color: #cccccc;
> background-image: none;
> padding: 6px 15px;
> spacing: 10px;
> text-shadow: none;
> }
>
> this seems to have no effect. we tried with RAP 2.1 and RAP 2.2 M2.
>
> Any Ideas (besides CTabFolder.setBackground(Color) ?
>
> Thanks
> Andrej
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: CTabItem background-color not themable? [message #1144429 is a reply to message #1139432] Fri, 18 October 2013 21:58 Go to previous message
Andrej Dimic is currently offline Andrej Dimic
Messages: 73
Registered: July 2009
Member
Hi Ivan

thank you very much for fixing this problem.

I will try it with the next available Milestone Build.

Cheers
Andrej
Previous Topic:Unresponsive script error in Combo widget
Next Topic:Label text is initially truncated
Goto Forum:
  


Current Time: Wed Oct 22 22:29:59 GMT 2014

Powered by FUDForum. Page generated in 0.01978 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software