Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse does not start up [Linux](ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter)
Eclipse does not start up [Linux] [message #1138746] Tue, 15 October 2013 09:46 Go to next message
Thomas Hartmann is currently offline Thomas HartmannFriend
Messages: 1
Registered: October 2013
Junior Member

my Eclipse installation crashes immediately after the start on Fedora 19.

The error log complains about a missing EclipseStarter class.

I have already tried to cleanly reinstall Eclipse as well as OpenJDK 1.7; I switched the alternatives for the Java installation and tried to run Eclipse letting -vm point to the dedicated javaws -- but all without success so far.

Maybe somebody has an idea for me?

Cheers and Thanks,

Error log:
!SESSION Tue Oct 15 11:40:57 CEST 2013 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2013-10-15 11:40:57.587
!MESSAGE Exception launching the Eclipse Platform:
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
	at Method)
	at java.lang.ClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
	at org.eclipse.equinox.launcher.Main.invokeFramework(
	at org.eclipse.equinox.launcher.Main.basicRun(
	at org.eclipse.equinox.launcher.Main.main(

StartUp log
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
CompilerOracle: exclude org/eclipse/tycho/core/osgitools/EquinoxResolver.newState

Re: Eclipse does not start up [Linux] [message #1139390 is a reply to message #1138746] Tue, 15 October 2013 18:47 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2578
Registered: July 2009
Senior Member
Don't use "javaw" when something's wrong. Instead, use the "java" binary and start Eclipse with the -consoleLog switch. How was this Eclipse installed?

Nitin Dahyabhai
Eclipse WTP, IBM

[Updated on: Tue, 15 October 2013 18:47]

Report message to a moderator

Re: Eclipse does not start up [Linux] [message #1706764 is a reply to message #1139390] Sun, 30 August 2015 17:07 Go to previous messageGo to next message
pampapathi kenchappa is currently offline pampapathi kenchappaFriend
Messages: 1
Registered: August 2015
Junior Member
i was downloaded tar file from site and i try to extracted from terminal there also at end of the extraction little problem after extracting opt folder. i created file in that i typed all the required data for eclips.desktop then i try to execute .

but it s not opening at all
  • Attachment: complaints
    (Size: 0.87KB, Downloaded 6 times)
Re: Eclipse does not start up [Linux] [message #1706773 is a reply to message #1706764] Mon, 31 August 2015 02:58 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2769
Registered: July 2009
Senior Member
You had an error during extraction? Whatever that error was, it's probably the root of the problem. The entire contents of the tar or zip needs to be extracted correctly in order for Eclipse to work. Try again, get a clean extraction and then see if Eclipse starts correctly.
Previous Topic:Disable "Confirm Perspective Switch" Dialog
Next Topic:Help with a annoyance
Goto Forum:

Current Time: Sun Nov 29 18:01:43 GMT 2015

Powered by FUDForum. Page generated in 0.01778 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software