Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Unmet Apache Lucene dependency when building Mylyn tasks project
Unmet Apache Lucene dependency when building Mylyn tasks project [message #1136606] Mon, 14 October 2013 01:22 Go to next message
Todd Schiller is currently offline Todd SchillerFriend
Messages: 3
Registered: June 2013
Location: Seattle
Junior Member
I'm trying to build the Mylyn tasks project (org.eclipse.mylyn.tasks.index.core) from a master Git checkout using Kepler (4.3) Service Release 1.

I'm getting some build errors since my environment is apparently missing Apache Lucene > 2.9.1 so I'm not meeting the dependency:

org.apache.lucene.core;bundle-version="[2.9.1,3.7.0)"

When adding a plug-in dependency, the search results seem to indicate that I have Apache Lucene 1.9.1, which is odd since Eclipse moved to Lucene 2.9.1 in version 3.7. I suspect that another installed plug-in is contributing the older version of Lucene and is somehow masking the version provided by Eclipse.

Has anyone encountered this problem before or have any suggestions for resolving the problem?

Thanks,
Todd
Re: Unmet Apache Lucene dependency when building Mylyn tasks project [message #1161263 is a reply to message #1136606] Tue, 29 October 2013 17:44 Go to previous message
Tomasz Zarna is currently offline Tomasz ZarnaFriend
Messages: 165
Registered: July 2009
Senior Member
Have you tried loading a target platform definition?

Cheers,
Tomek
Previous Topic:Custom Mylyn search handlers
Next Topic:Enter dates in Task Editor
Goto Forum:
  


Current Time: Fri Nov 28 02:05:08 GMT 2014

Powered by FUDForum. Page generated in 0.04985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software