Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Error creating JBoss 3.2.6 server runtime eclipse 3.2 (wtp 1.5)
Error creating JBoss 3.2.6 server runtime eclipse 3.2 (wtp 1.5) [message #174700] Mon, 17 July 2006 12:58 Go to next message
Eclipse User
Originally posted by: alice.sufka.ensequence.com

Anyone else come across this problem? :

When trying to define a new sever runtime for JBoss 3.2.x, cannot create
runtime if version 3.2.6 of JBoss is selected. The error "Missing
classpath
entry c:\jboss-3.2.6\server\default\lib\javax.servlet.jar" is displayed
and the
"Finish" button is disabled.

This occurs using the Server/Installed Runtimes preferences dialog.

The definition of a server runtime using the same procedure but pointing
to an
install of version 3.2.3 of JBoss does not give this error and completes
successfully.

A clean install of JBoss 3.2.6 does not have the javax.servlet.jar file
that
the eclipse process is looking for; I believe that the eclipse process is
looking for that file in error and that it should not be looking for that
file
for the 3.2.6 version of JBoss. Since the dialog is for the option of
defining
any 3.2.x JBoss runtime, I am guessing it is expecting all 3.2.x installs
of
JBoss to look alike when this is not the case.
Re: Error creating JBoss 3.2.6 server runtime eclipse 3.2 (wtp 1.5) [message #175526 is a reply to message #174700] Wed, 26 July 2006 15:21 Go to previous message
John Kenny is currently offline John Kenny
Messages: 62
Registered: July 2009
Member
Alice Sufka wrote:
>
> Anyone else come across this problem? :
>
> When trying to define a new sever runtime for JBoss 3.2.x, cannot create
> runtime if version 3.2.6 of JBoss is selected. The error "Missing
> classpath
> entry c:\jboss-3.2.6\server\default\lib\javax.servlet.jar" is displayed
> and the
> "Finish" button is disabled.
>
> This occurs using the Server/Installed Runtimes preferences dialog.
>
> The definition of a server runtime using the same procedure but pointing
> to an
> install of version 3.2.3 of JBoss does not give this error and completes
> successfully.
>
> A clean install of JBoss 3.2.6 does not have the javax.servlet.jar file
> that
> the eclipse process is looking for; I believe that the eclipse process is
> looking for that file in error and that it should not be looking for
> that file
> for the 3.2.6 version of JBoss. Since the dialog is for the option of
> defining
> any 3.2.x JBoss runtime, I am guessing it is expecting all 3.2.x
> installs of
> JBoss to look alike when this is not the case.
>


Any way to fix this?
Previous Topic:Adding New Legal File Types to XML Generate
Next Topic:java build path for Tomcat inside Eclipse?
Goto Forum:
  


Current Time: Thu Aug 21 02:37:32 EDT 2014

Powered by FUDForum. Page generated in 0.01515 seconds