Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » Problem with new org.apache.axis bundle
Problem with new org.apache.axis bundle [message #16469] Sun, 29 March 2009 09:40 Go to next message
Peter Kullmann is currently offline Peter Kullmann
Messages: 199
Registered: July 2009
Senior Member
I tried to use the new org.apache.axis bundle from the orbit build
I20090320075422. The bundle is not usable in PDE. I can add the bundle
to the target and PDE shows the bundle with its manifest but the
exported classes are not visible in eclipse. For a bundle using axis
code, the compiler complains "The import org.apache connot be resolved".

The bundle from S20090307012903 works as expected. Also, the newer
I20090320075422 bundle works if I unzip it. Apparently, the problem
comes from the fact that the newer bundle is jarred and the older one
was not. But I think, it should also work in the jarred form.

Best regards
Peter
Re: Problem with new org.apache.axis bundle [message #16487 is a reply to message #16469] Tue, 31 March 2009 16:49 Go to previous message
Eclipse User
Originally posted by: david_williams.linux.vnet.ibm.com

Peter Kullmann wrote:
> I tried to use the new org.apache.axis bundle from the orbit build
> I20090320075422. The bundle is not usable in PDE. I can add the bundle
> to the target and PDE shows the bundle with its manifest but the
> exported classes are not visible in eclipse. For a bundle using axis
> code, the compiler complains "The import org.apache connot be resolved".
>
> The bundle from S20090307012903 works as expected. Also, the newer
> I20090320075422 bundle works if I unzip it. Apparently, the problem
> comes from the fact that the newer bundle is jarred and the older one
> was not. But I think, it should also work in the jarred form.
>
I'm opened bug 270669 for this.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270669
Re: Problem with new org.apache.axis bundle [message #565273 is a reply to message #16469] Tue, 31 March 2009 16:49 Go to previous message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Peter Kullmann wrote:
> I tried to use the new org.apache.axis bundle from the orbit build
> I20090320075422. The bundle is not usable in PDE. I can add the bundle
> to the target and PDE shows the bundle with its manifest but the
> exported classes are not visible in eclipse. For a bundle using axis
> code, the compiler complains "The import org.apache connot be resolved".
>
> The bundle from S20090307012903 works as expected. Also, the newer
> I20090320075422 bundle works if I unzip it. Apparently, the problem
> comes from the fact that the newer bundle is jarred and the older one
> was not. But I think, it should also work in the jarred form.
>
I'm opened bug 270669 for this.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270669
Previous Topic:Problem with new org.apache.axis bundle
Next Topic:org.apache.velocity: add DynamicImport-Package: * to manifest
Goto Forum:
  


Current Time: Wed Aug 20 03:02:00 EDT 2014

Powered by FUDForum. Page generated in 0.01658 seconds