Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Intro Page not shown in Eclipse E4 Application Project
Intro Page not shown in Eclipse E4 Application Project [message #1131470] Thu, 10 October 2013 15:00 Go to next message
Rita Gomez is currently offline Rita GomezFriend
Messages: 2
Registered: October 2013
Junior Member
Hi everybody,

My problem is that the intro page is not shown when I launch the product.

I have followed the steps:

1. File - New - Project - Eclipse E4 Application Project, with the default settings
2. Add the extensions : org.eclipse.ui.intro, org.eclipse.ui.intro.universal Dependencies on the plugin.xml file and also in the *.product file.
3. Add and intro extension with its intro configuration just as shown on web tutorials.

When I launch the project it works fine but no intro page appears. I clear the workspace and I am using eclipse Kepler. Since this doesn't seem to be a bug, does anybody have any idea why is this happening?

Thanks in advance,
Re: Intro Page not shown in Eclipse E4 Application Project [message #1505852 is a reply to message #1131470] Wed, 10 December 2014 11:09 Go to previous messageGo to next message
Heiko Hollenbach is currently offline Heiko HollenbachFriend
Messages: 5
Registered: December 2014
Junior Member
I have run into the same problem.

public class MyIntroPart extends IntroPart {

	public void createPartControl(Composite container) {
		Composite outerContainer = new Composite(container, SWT.NONE);
		GridLayout gridLayout = new GridLayout();
		Label label = new Label(outerContainer, SWT.CENTER);
		label.setText("WELCOME TO ECLIPSE");
		GridData gd = new GridData(GridData.GRAB_HORIZONTAL | GridData.GRAB_VERTICAL);
		gd.horizontalAlignment = GridData.CENTER;
		gd.verticalAlignment = GridData.CENTER;

	public void standbyStateChanged(boolean standby) {


	public void setFocus() {



I selected the Welcome Page in the test.product under Branding.

i also have tried to remove the generetes workspace when Launch as Eclipse application.

What did i miss or what's the poroblem
Re: Intro Page not shown in Eclipse E4 Application Project [message #1702958 is a reply to message #1505852] Mon, 27 July 2015 14:51 Go to previous message
Andreas Maier is currently offline Andreas MaierFriend
Messages: 1
Registered: July 2015
Junior Member
Hi everybody,

same here. Does anyone know how to solve it?

kind regards
Previous Topic:How to make Eclipse IDE distribution
Next Topic:Migrating an existing Plugin RCP Product from one server to another
Goto Forum:

Current Time: Thu Nov 26 00:31:03 GMT 2015

Powered by FUDForum. Page generated in 0.01736 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software