Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » Latest Gemini Mgmt complies with OSGi spec version 4.2 or 5.0 or ... ?(I am seeking clarification on Gemini Management and Ent. OSGi spec version compliance - v4.2 or v5.0?)
Latest Gemini Mgmt complies with OSGi spec version 4.2 or 5.0 or ... ? [message #1130425] Wed, 09 October 2013 14:46 Go to next message
Richard Thomas is currently offline Richard ThomasFriend
Messages: 1
Registered: October 2013
Junior Member
I am seeking clarification on Gemini Management and Ent. OSGi spec version compliance - v4.2 or v5.0?

On the Gemini Home page (http://eclipse.org/gemini/), it states "Implements the JMX™ Management Model Specification defined in chapter 124 of the OSGi 4.2 Enterprise Specification" (see

first sentence of "Gemini Management" paragraph).

On the Gemini Management release notes page (http://www.eclipse.org/gemini/management/download/release-notes/2.0.0.RELEASE.php), it states "The major theme for the 2.0.x line is

compatibility with the Enterprise OSGi 5.0 specification." Inspection of downloaded 2.0.0 binaries (org.eclipse.gemini.management-2.0.0.RELEASE.jar) and sources

(org.eclipse.gemini.management-2.0.0.RELEASE-sources.jar) shows file latest file mod dates of April 2013. Also, last known bug was closed April 2013

(https://bugs.eclipse.org/bugs/buglist.cgi?query_format=advanced&classification=RT&product=Gemini.Management&target_milestone=2.0.0.RELEASE).

Questions:
(a) Doesn't 2.0.0 release imply v5.0 spec compliance?
(b) Why doesn't Gemini Home page (http://eclipse.org/gemini/) state that Gemini Management complies with v5.0 (but instead asserts v4.2 compliance)?

Re: Latest Gemini Mgmt complies with OSGi spec version 4.2 or 5.0 or ... ? [message #1130697 is a reply to message #1130425] Wed, 09 October 2013 21:11 Go to previous message
Florian Waibel is currently offline Florian WaibelFriend
Messages: 100
Registered: June 2010
Senior Member
Richard Thomas wrote on Wed, 09 October 2013 10:46
I am seeking clarification on Gemini Management and Ent. OSGi spec version compliance - v4.2 or v5.0?


Thanks for pointing out this ambiguity / inconsistency in the Gemini Management documentation.

Quote:
(a) Doesn't 2.0.0 release imply v5.0 spec compliance?


As stated in the release notes the Release 2.0.0 is compatible with the Enterprise OSGi 5.0 specification.

Quote:
(b) Why doesn't Gemini Home page (http://eclipse.org/gemini/) state that Gemini Management complies with v5.0 (but instead asserts v4.2 compliance)?


This is simply an outdated information. Sorry for any inconvenience caused by this.

I will take care of updating the homepage as soon as possible.

Regards,
florian
Previous Topic:Problem resolving blueprint.xsd
Next Topic:Having issues with Kepler SR1 and Gemini Web
Goto Forum:
  


Current Time: Thu Dec 18 12:45:06 GMT 2014

Powered by FUDForum. Page generated in 0.02312 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software