Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Propagated component name becomes of 'unknown' type by some reason
Propagated component name becomes of 'unknown' type by some reason [message #1129187] Tue, 08 October 2013 11:27 Go to next message
Alexander Kolesov is currently offline Alexander Kolesov
Messages: 36
Registered: November 2012
Member
Hello Jubula team.

Jubula standalone version: 7.1.0

Could you please take a look ay the following problem - sometimes common component name (like nn_nn_text) obtains type 'Unknown' that leads to impossibility of using keywords with propagated component names, therefore it is required to drop current test db revision and return to previous version (at least a whole working day is lost).

1. Here is a screen where 'nn_TreeTable' became 'Unknown'
index.php/fa/16417/0/

2. Here is a screen where this component name is used.
index.php/fa/16418/0/

3. And here is an error when I insert real component name of 'TreeTable' type.
index.php/fa/16419/0/

Please note that all that has been working for monthes, and it is a second time to happen. Unfortunattelly I can not provide scenario of how reproduce the issue.
  • Attachment: UnknownType.PNG
    (Size: 28.17KB, Downloaded 149 times)
  • Attachment: propagated.PNG
    (Size: 15.10KB, Downloaded 147 times)
  • Attachment: Error.PNG
    (Size: 9.99KB, Downloaded 150 times)

[Updated on: Tue, 08 October 2013 12:26]

Report message to a moderator

Re: Propagated component name becomes of 'unknown' type by some reason [message #1130430 is a reply to message #1129187] Wed, 09 October 2013 14:52 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi there,

Thanks for the description, and sorry for the pain. I think that circumstances like this may happen when component names hierarchies have been "broken" (propagated, perhaps with renaming, and then propagation removed). I also don't know how to reproduce it though.

If it does happen again, then you could try looking for all places where the name is used (f7 in the component names browser) and seeing if you can find the place where it is unknown. Making changes to that test case, or checking that the hierarchy is correct may help you to fix the issue. Perhaps export / import would also help, but I'm not sure.

Keep us updated!
Alex
Re: Propagated component name becomes of 'unknown' type by some reason [message #1131209 is a reply to message #1130430] Thu, 10 October 2013 09:49 Go to previous messageGo to next message
Alexander Kolesov is currently offline Alexander Kolesov
Messages: 36
Registered: November 2012
Member
Hi Alexandra,

Thanks, I will try to use proposed attempts to fix the issue if it ever happens again (hope to be so lucky not use the workaround Smile ).
Maybe it makes sense for developers to take a look and fix such component state changing?
I think that it is not expected from GUI to break internal structure.

Thanks,
Alex.
Re: Propagated component name becomes of 'unknown' type by some reason [message #1175188 is a reply to message #1131209] Thu, 07 November 2013 15:33 Go to previous messageGo to next message
Alexander Kolesov is currently offline Alexander Kolesov
Messages: 36
Registered: November 2012
Member
Hi Alexandra,
The same issue happened again. Import/export did not help.
Trying F7 in component browser did not show the place where it is unknown.

Thanks, Alexander.



Re: Propagated component name becomes of 'unknown' type by some reason [message #1176371 is a reply to message #1175188] Fri, 08 November 2013 09:38 Go to previous message
Alexander Kolesov is currently offline Alexander Kolesov
Messages: 36
Registered: November 2012
Member
Hi,

I beleive that I found the way to fix the problem, at least component stopped to be of Unknown type and can be used now.
1. Export corrupted project.
2. Search corrupted component in xml dump. It will look like:
<componentNames><compType>guidancer.abstract.unknown</compType><GUID>a79efa110e31490cabeb0afa7ed13f30</GUID><creationContext>OVERRIDDEN_NAME</creationContext><refGuid xsi:nil="true"/><compName>nn_TreeTable</compName></componentNames>
3. Replace <compType>guidancer.abstract.unknown</compType> with proper class for component, in my case it is <compType>org.eclipse.swt.widgets.SwtTree</compType>.
4. Save and import modified xml to DB.

Hope it will help.
Thanks,
Alexander.
Previous Topic:Error 7009
Next Topic:Writing plugin extension for Jubula
Goto Forum:
  


Current Time: Sun Oct 26 05:08:54 GMT 2014

Powered by FUDForum. Page generated in 0.23102 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software