Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » jsp editor error when using struts logic tag
jsp editor error when using struts logic tag [message #171958] Wed, 21 June 2006 19:46 Go to next message
John Kenny is currently offline John Kenny
Messages: 62
Registered: July 2009
Member
In a JSP fragment opened in the WTP JSP editor I am using the struts
logic iterate tag like this:

<logic:iterate id="curReco" name="confP" property="confRecoVector">
if (recoResult == "<%= curReco %>") {
src = "<%= (String)
confP.getConfPHashMap().get(curReco+ConfPBean.RECORESULTSRC) %>";
alttext = "<%= (String)
confP.getConfPHashMap().get(curReco+ConfirmPBean.RECORESULTA LTTEXT) %>";
}
</logic:iterate>

The id attribute of the struts <logic:iterate> tag (which I am calling
curReco) indicates a page bean that will represent the current item I am
iterating through.

The JSP editor marks the use of curReco as an error saying: "curReco
cannot be resolved"

What can I do to resolve this editor error?

Thanks,
John
Re: jsp editor error when using struts logic tag [message #178115 is a reply to message #171958] Tue, 29 August 2006 05:57 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2314
Registered: July 2009
Senior Member
John Kenny wrote:
> In a JSP fragment opened in the WTP JSP editor I am using the struts
> logic iterate tag like this:
>
> <logic:iterate id="curReco" name="confP" property="confRecoVector">
> if (recoResult == "<%= curReco %>") {
> src = "<%= (String)
> confP.getConfPHashMap().get(curReco+ConfPBean.RECORESULTSRC) %>";
> alttext = "<%= (String)
> confP.getConfPHashMap().get(curReco+ConfirmPBean.RECORESULTA LTTEXT) %>";
> }
> </logic:iterate>
>
> The id attribute of the struts <logic:iterate> tag (which I am calling
> curReco) indicates a page bean that will represent the current item I am
> iterating through.
>
> The JSP editor marks the use of curReco as an error saying: "curReco
> cannot be resolved"
>
> What can I do to resolve this editor error?

It's an internal error that we hope to have resolved in 1.5.1.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=87143

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Dynamic Web project
Next Topic:Eclipse PHP IDE and HTML code assist
Goto Forum:
  


Current Time: Fri Oct 31 18:07:50 GMT 2014

Powered by FUDForum. Page generated in 0.01495 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software