Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » No available factory; defaulting to DefaultArtifactFactory
No available factory; defaulting to DefaultArtifactFactory [message #16191] Wed, 01 July 2009 10:59 Go to next message
Mark D-B is currently offline Mark D-B
Messages: 188
Registered: July 2009
Senior Member
For my new artifact types, I am getting messages in the OSEE client osgi
window of the form:

Wed Jul 01 15:45:52 BST 2009
org.eclipse.osee.framework.skynet.core.SkynetA
ctivator
INFO
org.eclipse.osee.framework.skynet.core.artifact.factory.Arti factFactoryMa
nager getFactory (58)
No available factory; defaulting to DefaultArtifactFactory for: Physical
IO pin

where "Physical IO pin" is one of these artifact types.

Is this normal, or did something go wrong when I imported my type?
Re: No available factory; defaulting to DefaultArtifactFactory [message #16285 is a reply to message #16191] Thu, 16 July 2009 22:53 Go to previous message
Ryan D. Brooks is currently offline Ryan D. Brooks
Messages: 100
Registered: July 2009
Senior Member
Mark,

This was an informational message that was added during a refactor to
ensure no factory mappings were missed. It does not indicate that you did
anything incorrectly and we have now removed the message from the code.

Regards,
Ryan


Thanks,
Ryan Brooks
Re: No available factory; defaulting to DefaultArtifactFactory [message #574443 is a reply to message #16191] Thu, 16 July 2009 22:53 Go to previous message
Ryan D. Brooks is currently offline Ryan D. Brooks
Messages: 100
Registered: July 2009
Senior Member
Mark,

This was an informational message that was added during a refactor to
ensure no factory mappings were missed. It does not indicate that you did
anything incorrectly and we have now removed the message from the code.

Regards,
Ryan


Thanks,
Ryan Brooks
Previous Topic:Need help creating extension point for mail server please
Next Topic:Native Editor generates an exception
Goto Forum:
  


Current Time: Tue Jul 29 11:04:07 EDT 2014

Powered by FUDForum. Page generated in 0.01645 seconds