Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Application.launch() hangs
Application.launch() hangs [message #1123105] Wed, 02 October 2013 07:47 Go to next message
Filip Deleersnijder is currently offline Filip Deleersnijder
Messages: 10
Registered: October 2013
Junior Member
Hi,

We are trying to make a proof of concept with an OSGi-bundle that launches a JavaFX Application when starting its Activator.

The code is very simple : In the Activator we make a "HelloWorld" object ( HelloWorld extends Application) and call a method to start it. Internally, this method calls Application.launch(). The code hangs at the moment that Application.launch() is called.

We used the preconfigured Eclipse (4.2.2) installation downloaded from (efxclipse.bestsolution.at/install.html#all-in-one) and the target platform from this website ( download.eclipse.org/efxclipse/runtime-nightly/site). We provided this option to OSGi: "-Dosgi.framework.extensions=org.eclipse.fx.osgi"

At this link (docs.google.com/a/motum.be/file/d/0B2aFUSe8nJC0YWVvYThGMGdwbG8/edit?usp=sharing), you can find the source code for this bundle (including the launch configuration) to reproduce this problem.

We are running OS-X (10.8.2) with JDK7_u40.

Thanks in advance for any help,

Filip

PS: Sorry, I had to omit "http://" from all my links, because a some forum constraint since I am relatively new to this forum.
Re: Application.launch() hangs [message #1124188 is a reply to message #1123105] Thu, 03 October 2013 09:11 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5330
Registered: July 2009
Senior Member
Just for reference this was a problem of starting with PDE defaults! See
https://groups.google.com/forum/#!topic/efxclipse/zMlr-famQF0

Tom

On 02.10.13 19:29, FIlip Deleersnijder wrote:
> Hi,
>
> We are trying to make a proof of concept with an OSGi-bundle that
> launches a JavaFX Application when starting its Activator.
>
> The code is very simple : In the Activator we make a "HelloWorld" object
> ( HelloWorld extends Application) and call a method to start it.
> Internally, this method calls Application.launch(). The code hangs at
> the moment that Application.launch() is called.
>
> We used the preconfigured Eclipse (4.2.2) installation downloaded from
> (efxclipse.bestsolution.at/install.html#all-in-one) and the target
> platform from this website (
> download.eclipse.org/efxclipse/runtime-nightly/site). We provided this
> option to OSGi: "-Dosgi.framework.extensions=org.eclipse.fx.osgi"
>
> At this link
> (docs.google.com/a/motum.be/file/d/0B2aFUSe8nJC0YWVvYThGMGdwbG8/edit?usp=sharing),
> you can find the source code for this bundle (including the launch
> configuration) to reproduce this problem.
> We are running OS-X (10.8.2) with JDK7_u40.
>
> Thanks in advance for any help,
>
> Filip
>
> PS: Sorry, I had to omit "http://" from all my links, because a some
> forum constraint since I am relatively new to this forum.
Previous Topic:Tutorial 1 fails on Ant Build and is very slow
Next Topic:Building OSGi-JavaFX program into jars
Goto Forum:
  


Current Time: Sat Sep 20 04:14:53 GMT 2014

Powered by FUDForum. Page generated in 0.01664 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software