Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT and prototype.js security vulnerabilities(BIRT and prototype.js security vulnerabilities)
BIRT and prototype.js security vulnerabilities [message #1122525] Tue, 01 October 2013 13:15 Go to next message
Anthony Farrell is currently offline Anthony Farrell
Messages: 29
Registered: August 2012
Junior Member
BIRT 2.6.1 ships with version 1.4 of prototype.js, I see BIRT version 4.3.1 ships with prototype.js version 1.7.


There are security issues with version 1.4 of prototype.js, is there a documented process for getting BIRT 2.6.1 to work with prototype.js version 1.7 ?

As part of getting prototype 1.7 working with BIRT 4.3.1 I guess there is the a list of .javascript files or servlets that are impacted resulting from version 1.7 of prototype.js. Is it possible to get that list?

Is it best to upgrade to work around the security issues that come with version 1.4 of prototype.js ?

Regards,
Anthony.



[Updated on: Fri, 04 October 2013 08:13]

Report message to a moderator

Re: BIRT and prototype.js security vulnerabilities [message #1139299 is a reply to message #1122525] Tue, 15 October 2013 13:30 Go to previous message
Michael Williams is currently offline Michael Williams
Messages: 1424
Registered: July 2009
Senior Member

You could file a bug and see if they have a list of upgrades they made to upgrade to 1.7 that they could post. Upgrading to 4.3 is probably the best, if you can though.

Michael
Actuate – The BIRT Company™

BIRT Developer Center
Check out the new, free BIRT Viewer Toolkit
Previous Topic:BIRT move the webcontent folder to WEB-INF ?
Next Topic:Birt is not OSGi ready? [SOLVED]
Goto Forum:
  


Current Time: Sun Apr 20 15:53:11 EDT 2014

Powered by FUDForum. Page generated in 0.01821 seconds