Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » EMF generating compile errors with enums
EMF generating compile errors with enums [message #1122524] Tue, 01 October 2013 17:12 Go to next message
Rui Domingues is currently offline Rui Domingues
Messages: 191
Registered: October 2010
Senior Member
I'm posting because I've an ecore model where one abstract class inside a subpackage has an attribute typed with an enumeration I've defined.

That class Implementation is generated with compile errors on eSet Method, since inside the case of the switch it is missing a cast.

Is this a known bug, or am I doing something wrong.


I've shrunken the model in order to isolate the test case and it is sent as attachment.

  • Attachment: model.ecore
    (Size: 0.96KB, Downloaded 18 times)

[Updated on: Tue, 01 October 2013 17:19]

Report message to a moderator

Re: EMF generating compile errors with enums [message #1122530 is a reply to message #1122524] Tue, 01 October 2013 17:18 Go to previous message
Rui Domingues is currently offline Rui Domingues
Messages: 191
Registered: October 2010
Senior Member
Bug filed : https://bugs.eclipse.org/bugs/show_bug.cgi?id=418442
Previous Topic:[CDO] NPE in CDOResourceImpl.basicSetResource
Next Topic:How to fill AnyType mixed content with Java code
Goto Forum:
  


Current Time: Mon Sep 22 08:31:28 GMT 2014

Powered by FUDForum. Page generated in 0.03948 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software