Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » DeploymentDescriptorLoadException without a obvious reason
DeploymentDescriptorLoadException without a obvious reason [message #170597] Mon, 05 June 2006 16:26
Lars Francke is currently offline Lars FranckeFriend
Messages: 2
Registered: July 2009
Junior Member
I am using the latest Callisto release (RC4) and at the beginning
everything worked fine but a few RCs ago I began to receive the following

!ENTRY org.eclipse.wst.validation 4 0 2006-06-05 17:34:08.234
*** ERROR ***: Mon Jun 05 17:34:08 CEST 2006
org.eclipse.jst.j2ee.commonarchivecore.internal.exception.De ploymentDescriptorLoadException:
Stack trace of nested exception:

org.eclipse.jst.j2ee.commonarchivecore.internal.exception.Em ptyResourceException:
platform:/resource/careercockpit-web/src/main/webapp/WEB-INF /web.xml
org.eclipse.jst.j2ee.commonarchivecore.internal.util.Archive Util.getRoot(
org.eclipse.jst.j2ee.commonarchivecore.internal.strategy.Xml BasedImportStrategyImpl.primLoadDeploymentDescriptor(XmlBase
org.eclipse.jst.j2ee.commonarchivecore.internal.strategy.War 22ImportStrategyImpl.loadDeploymentDescriptor(War22ImportStr
org.eclipse.jst.j2ee.commonarchivecore.internal.strategy.War 22ImportStrategyImpl.importMetaData(War22ImportStrategyImpl. java:81)
org.eclipse.jst.j2ee.commonarchivecore.internal.impl.WARFile Impl.getDeploymentDescriptor(
org.eclipse.jst.j2ee.model.internal.validation.WarValidator. validateInJob(
org.eclipse.jst.j2ee.internal.web.validation.UIWarValidator. validateInJob(
org.eclipse.wst.validation.internal.operations.ValidatorJob. run(

I know that the web.xml is correct and in the folder it is supposed to be.
This first began after a refresh of the project and has stayed ever since.
I did not change anything in the web.xml.

I did subsequent tests and created an empty new Dynamic Web Project and
refreshed it a few times and the same error message came up. And this on a
fresh and unchanged project.

Something must be wrong. Does anyone else see this kind of behaviour? I
have found Rob Williams' blog entry on the same subject: _wtp_shenanigans

But no solution there either.

Can anyone help?

Thank you,
Previous Topic:Tomcat 5 context/application files
Next Topic:webdoclet merge dir
Goto Forum:

Current Time: Mon Oct 05 15:29:15 GMT 2015

Powered by FUDForum. Page generated in 0.11174 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software