Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Dependency version problem in equinox launchers
Dependency version problem in equinox launchers [message #1120139] Sun, 29 September 2013 04:02 Go to next message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 213
Registered: July 2009
Senior Member
Hi all,

I've been using a Jenkins job for creating RCP products with Buckminster.

Since a few days I get the following error:

[ant] Cannot complete the install because of a conflicting dependency.
[ant]  Software being installed: org.xxx.product 1.0.0
[ant]  Only one of the following can be installed at once: 
[ant]   Equinox Launcher Linux X86_64 Fragment 1.1.200.v20130807-1835 
(org.eclipse.equinox.launcher.gtk.linux.x86_64 1.1.200.v20130807-1835)
[ant]   Equinox Launcher Linux X86_64 Fragment 1.1.200.v20130521-0416 
(org.eclipse.equinox.launcher.gtk.linux.x86_64 1.1.200.v20130521-0416)
[ant]  Cannot satisfy dependency:
[ant]   From: org.xxx.product 1.0.0
[ant]   To: org.eclipse.equinox.launcher.gtk.linux.x86_64 [1.1.200.v20130521-0416]
[ant]  Cannot satisfy dependency:
[ant]   From: org.xxx.product 1.0.0
[ant]   To: org.eclipse.equinox.launcher.gtk.linux.x86_64 [1.1.200.v20130807-1835]
[ant] Cannot complete the install because of a conflicting dependency.
[ant] Software being installed: org.xxx.product 1.0.0
[ant] Only one of the following can be installed at once: 
[ant] Cannot satisfy dependency:
[ant] Cannot satisfy dependency:
[ant] A problem occured while invoking the director.


To get further details I reviewed the file content.xml (content.jar) of the
p2 site feature. Thereby I discovered the following dependencies:

1) org.eclipse.e4.rcp.feature.group (1.2.0.v20130605-1738)
2) org.eclipse.equinox.executable.feature.group (3.6.0.v20130807-1835)

Both features require org.eclipse.equinox.launcher with range
[1.3.0.v20130327-1440,1.3.0.v20130327-1440] - that part looks fine.

But when it comes to the native launcher fragments there occur differences.
The following shows the dependency ranges for
org.eclipse.equinox.launcher.gtk.linux.x86_64 as example:

1) requires range [1.1.200.v20130521-0416,1.1.200.v20130521-0416]
2) requires range [1.1.200.v20130807-1835,1.1.200.v20130807-1835]

So obviously the problem seems to be causes by inconsistencies at the
Eclipse sites.

Can anybody confirm this? Is there any workaround for that problem?

Regards,

Axel

[Updated on: Sun, 29 September 2013 04:07]

Report message to a moderator

Re: Dependency version problem in equinox launchers [message #1120149 is a reply to message #1120139] Sun, 29 September 2013 04:17 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 213
Registered: July 2009
Senior Member
Nevermind. I think I found the dependency chain now.
Previous Topic:Trigger Xtend 2 builder in a headless CI job using ant / classpath problem
Next Topic:Build is slow with buckminster 4.2
Goto Forum:
  


Current Time: Mon Jul 28 22:46:02 EDT 2014

Powered by FUDForum. Page generated in 0.03393 seconds