Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EMF2DOMSSE Adapter does get proper notifications
EMF2DOMSSE Adapter does get proper notifications [message #169944] Tue, 23 May 2006 20:14 Go to next message
Sandro Schiefner is currently offline Sandro Schiefner
Messages: 13
Registered: July 2009
Junior Member
Hi,

I have a Scenario in that I overwrite an attribute name:

<element attribute1="value1"/>

to

<element attribute2="value1"/>

by just selecting the attribute1 attribute name and via autocompletion
change it to attribute2.

By doing this, I get 2 SET Notifications from the DOM, but only one SET
Notification for my EMF.

I am using Eclipse3.2M5a and installed WTP and EMF via Callisto...
Re: EMF2DOMSSE Adapter does get proper notifications [message #169991 is a reply to message #169944] Tue, 23 May 2006 22:31 Go to previous messageGo to next message
Sandro Schiefner is currently offline Sandro Schiefner
Messages: 13
Registered: July 2009
Junior Member
Hi,

In an other Scenario I get no notification at all:

<element attribute1="value1"/>

change it to:

<element attribute="value1"/>

where attribute is not in my EMF-Model.
I expect a set notification for my EMF-Model, that says that the value
of attribute1 is null...

sandro



Sandro wrote:
> Hi,
>
> I have a Scenario in that I overwrite an attribute name:
>
> <element attribute1="value1"/>
>
> to
>
> <element attribute2="value1"/>
>
> by just selecting the attribute1 attribute name and via autocompletion
> change it to attribute2.
>
> By doing this, I get 2 SET Notifications from the DOM, but only one SET
> Notification for my EMF.
>
> I am using Eclipse3.2M5a and installed WTP and EMF via Callisto...
>
>
>
>
Re: EMF2DOMSSE Adapter does get proper notifications [message #171273 is a reply to message #169991] Thu, 15 June 2006 07:43 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2272
Registered: July 2009
Senior Member
Thanks for sharing your problems with the newsgroup. The best way to
get these
handled (so the problems don't get lost in everyone's readers) is to
open bug
reports. Problems with the EMF2DOMSSE adapters should be opened
against the XML component:

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Web%20To ols&component=wst.xml

Please be sure to include the level of detail you've posted here.

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:How do I work around "Unsupported Content Type" error for HTML
Next Topic:SourceViewer with StructuredTextViewerConfigurationXML - Exception
Goto Forum:
  


Current Time: Thu Sep 18 22:00:54 GMT 2014

Powered by FUDForum. Page generated in 0.02755 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software