Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Setting base URL with genReport(How do I set the base url when generating a report with genReport)
Setting base URL with genReport [message #1117881] Thu, 26 September 2013 22:29 Go to next message
Eric Muehlstein is currently offline Eric MuehlsteinFriend
Messages: 6
Registered: June 2013
Junior Member
I'm running my report using the genReport script and outputting to PDF. In the PDF there are drill-through links which are generated with relative urls. For example, when I hover over one of the drill-throughs it shows a link to file:///path/to/PDF/...

I would like to set the base url for the report output so that I can point the drill-throughs back to my report viewer tomcat server.

I've experimented with "genReport.sh -r" but none of the options I've tried setting have any effect.

Any suggestions would be appreciated.
Re: Setting base URL with genReport [message #1121809 is a reply to message #1117881] Tue, 01 October 2013 01:14 Go to previous message
Eric Muehlstein is currently offline Eric MuehlsteinFriend
Messages: 6
Registered: June 2013
Junior Member
I was able to work around this issue by setting the base_url in viewer.properties and then fetching the reports with wget.
Previous Topic:Chart Wizard Launcher in OSGI mode
Next Topic:Resizing images for DOC output does not work
Goto Forum:
  


Current Time: Fri Nov 28 17:32:07 GMT 2014

Powered by FUDForum. Page generated in 0.01775 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software