Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » StaticWeave, Windows, and Stack Trace Line Numbers
StaticWeave, Windows, and Stack Trace Line Numbers [message #1115224] Mon, 23 September 2013 21:21 Go to next message
Scott Dudley is currently offline Scott DudleyFriend
Messages: 21
Registered: October 2012
Junior Member

We're using eclipselink-2.4.0 in a JSE application.

A co-worker informed me today that the line numbers reported in stack traces on his system for woven entity classes never "jive" with the source. They're fine on my machine. He runs Windows and I Linux.

I decompiled his woven class file and it clearly has additional blank lines that mine does not.

Why would org.eclipse.persistence.tools.weaving.jpa.StaticWeave behave differently depending on OS? Is there something that I can set in to correct this?

Thanks.
Re: StaticWeave, Windows, and Stack Trace Line Numbers [message #1115273 is a reply to message #1115224] Mon, 23 September 2013 23:12 Go to previous message
Scott Dudley is currently offline Scott DudleyFriend
Messages: 21
Registered: October 2012
Junior Member
Disregard. He discovered that he had the wrong EOL chars set in his editor (PC vs Unix). Thanks.
Previous Topic:Moxy logging configuration
Next Topic:Null handling in 2.5
Goto Forum:
  


Current Time: Sat Dec 20 15:13:11 GMT 2014

Powered by FUDForum. Page generated in 0.02657 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software