Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » JSP Editor and Comments
JSP Editor and Comments [message #168832] Tue, 09 May 2006 15:06 Go to next message
Eclipse User
Originally posted by: david.rushtone.com

I'm using Eclipse 3.1.2 with Webtools, uh, 1.0.1 I think? I downloaded
and installed wtp-all-in-one-sdk-R-1.0.1-200602171228.win32.zip.

But when I'm editing JSP files, using the "JSP Editor", it's flagging
the JSP comments <%-- such as this --%> as errors (more specifically, it
tends to choke on some text inside the comment delimiters).

Shouldn't the JSP editor know what a JSP comment is?

David
Re: JSP Editor and Comments [message #168925 is a reply to message #168832] Wed, 10 May 2006 11:28 Go to previous messageGo to next message
Eclipse User
Originally posted by: david.rushtone.com

The problem seems to be isolated to JSP comments that are inside of HTML
elements. I had used JSP comments to "comment out" some attributes of
HTML elements. Moving the comment outside of the HTML element avoids
their being marked as errors.

David

David Rush wrote:
> I'm using Eclipse 3.1.2 with Webtools, uh, 1.0.1 I think? I downloaded
> and installed wtp-all-in-one-sdk-R-1.0.1-200602171228.win32.zip.
>
> But when I'm editing JSP files, using the "JSP Editor", it's flagging
> the JSP comments <%-- such as this --%> as errors (more specifically, it
> tends to choke on some text inside the comment delimiters).
>
> Shouldn't the JSP editor know what a JSP comment is?
>
> David
Re: JSP Editor and Comments [message #168984 is a reply to message #168925] Wed, 10 May 2006 22:22 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Wed, 10 May 2006 11:28:04 -0400, David Rush <david@rushtone.com> wrote:

> The problem seems to be isolated to JSP comments that are inside of HTML
> elements.

We've fixed this in our 1.5 stream ....
https://bugs.eclipse.org/bugs/show_bug.cgi?id=98258

We do not plan to "back port" it, as its a bit risky to change parsers
in maintenance streams. Just wanted to let you know.
Re: JSP Editor and Comments [message #169238 is a reply to message #168984] Fri, 12 May 2006 09:50 Go to previous message
Eclipse User
Originally posted by: david.rushtone.com

David Williams wrote:
> On Wed, 10 May 2006 11:28:04 -0400, David Rush <david@rushtone.com> wrote:
>
>> The problem seems to be isolated to JSP comments that are inside of
>> HTML elements.
>
> We've fixed this in our 1.5 stream ....
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=98258
>
> We do not plan to "back port" it, as its a bit risky to change parsers
> in maintenance streams. Just wanted to let you know.
>
>

Cool. Thanks for the info.

David
Previous Topic:My Dynamic Web Projects suddenly became "Other" projects
Next Topic:Is there plans for another type of EJB wizard than XDoclet?
Goto Forum:
  


Current Time: Thu Jul 31 11:36:40 EDT 2014

Powered by FUDForum. Page generated in 0.02565 seconds