Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP don't compile change
WTP don't compile change [message #168305] Tue, 02 May 2006 15:19 Go to next message
Eclipse User
Originally posted by: scauvi.publicis.fr

Hi,

In a very small and simple WTP web project that ran successfully on JBoss
I add a new method in a class of the project. Then it was impossible to
get this method to be executed. I finally watched the .class file, the new
method wasn't in the compiled class, the class hasn't been compiled after
the code changed. I tryed to build the project again, move the method in
the class, close eclipse, open eclipse, close and open the project,
publish the project, etc, etc. I was unable to get this class compiled
again with the new code, I even deleted the class file from the build
directory and now when I run the project after it was published again,
logicaly, I get a ClassNotFoundExeption!

I lost a hudge amount of time with this silly and crazy problem, does
someone could help me to solve this big problem: Making this class to get
compiled within this Eclipse/Wtp project? Should I use Netbean, command
line Javac instead maybe?

Steph.
Re: WTP don't compile change [message #168316 is a reply to message #168305] Tue, 02 May 2006 16:07 Go to previous messageGo to next message
Eclipse User
Originally posted by: scauvi.publicis.fr

I forgot some important point: I am running eclipse 3.1.2 with wtp 1.0.2.
Re: WTP don't compile change [message #171222 is a reply to message #168305] Thu, 15 June 2006 06:49 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2269
Registered: July 2009
Senior Member
Stephane,
If you're still seeing those problems, please do open a bug report
so it can be looked into.

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Web%20To ols&component=jst.j2ee&version=1.0.2

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: WTP don't compile change [message #171366 is a reply to message #168305] Fri, 16 June 2006 07:03 Go to previous message
Eclipse User
Originally posted by: marx.nospam_wasko.pl

Stephane Cauvi napisa?(a):
>
> Hi,
>
> In a very small and simple WTP web project that ran successfully on
> JBoss I add a new method in a class of the project. Then it was
> impossible to get this method to be executed. I finally watched the
> .class file, the new method wasn't in the compiled class, the class
> hasn't been compiled after the code changed. I tryed to build the
> project again, move the method in the class, close eclipse, open
> eclipse, close and open the project, publish the project, etc, etc. I
> was unable to get this class compiled again with the new code, I even
> deleted the class file from the build directory and now when I run the
> project after it was published again, logicaly, I get a
> ClassNotFoundExeption!
>
> I lost a hudge amount of time with this silly and crazy problem, does
> someone could help me to solve this big problem: Making this class to
> get compiled within this Eclipse/Wtp project? Should I use Netbean,
> command line Javac instead maybe?
>
> Steph.
>
Change your classpath, for example add/remove some .jar file from project
Look also at "errors" (windows->show view->errors)
Eclipse is stupid and if you for example delete jar it needs to compile
some classes, it deletes all classes without any warning. The same when
Eclipse need rebuild project, and you are using one of folders in
classes directory - then Eclipse isn't able to delete classes folder and
will not rebuild project at all.
Marx
Previous Topic:How to publish jars to WEB-INF/lib?
Next Topic:Dynamic Web Project with old project structure
Goto Forum:
  


Current Time: Thu Sep 18 11:50:26 GMT 2014

Powered by FUDForum. Page generated in 0.02517 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software