Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP 1.0 to 1.5 API/extension points migration guide
WTP 1.0 to 1.5 API/extension points migration guide [message #167894] Fri, 28 April 2006 17:40 Go to next message
Max Rydahl Andersen is currently offline Max Rydahl Andersen
Messages: 224
Registered: July 2009
Senior Member
Hi,

Anyone know of a WTP 1.0 to 1.5 API/extension points migration guide ?

I'm currently struggling with porting from 1.0 XML handling to WTP 1.5.
I get no warning nor compile errors; but nothing is working ;(

So I have the feeling some extension point has changed name or behavior
so any tips appreciated ;)

/max
Re: WTP 1.0 to 1.5 API/extension points migration guide [message #168014 is a reply to message #167894] Sat, 29 April 2006 14:47 Go to previous messageGo to next message
Max Rydahl Andersen is currently offline Max Rydahl Andersen
Messages: 224
Registered: July 2009
Senior Member
so, I figured it out and it is *very* suttle!

I had the following before (worked in everything pre-1.5)

<content-type
base-type="org.eclipse.core.runtime.xml"
file-extensions="xml"
id="content-type.hbm.xml"
name="Hibernate Mapping Content-Type"
priority="normal">

id's can apparently not contain dot's (I remember some other issue with
the core platform regarding this)

so the following works:

<content-type
base-type="org.eclipse.core.runtime.xml"
file-extensions="xml"
id="hbmxmlsource"
name="Hibernate Mapping Content-Type"
priority="normal">

Can anyone tell me why ? And if it is so, why doesn't something complain
hard when a content-type id contains dot's ?

/max

> Hi,
>
> Anyone know of a WTP 1.0 to 1.5 API/extension points migration guide ?
>
> I'm currently struggling with porting from 1.0 XML handling to WTP 1.5.
> I get no warning nor compile errors; but nothing is working ;(
>
> So I have the feeling some extension point has changed name or behavior
> so any tips appreciated ;)
>
> /max



--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
Re: WTP 1.0 to 1.5 API/extension points migration guide [message #168053 is a reply to message #167894] Sun, 30 April 2006 03:13 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 28 Apr 2006 13:40:52 -0400, Max Rydahl Andersen
<max.andersen@jboss.com> wrote:

>
> Anyone know of a WTP 1.0 to 1.5 API/extension points migration guide ?
>

Max, there shouldn't be that much (famous last words :) but there are some
things
known issues listed in

http://wiki.eclipse.org/index.php/New_Help_for_Old_Friends

Let us know if we've forgotten something in that document, or if you have
other questions
on migration.

(To mention an "obvious" one, that may not be so obvious to eveyong ...
1.5 does require Eclipse 3.2,
one of the latest RC's would be good.)

HTH
Re: WTP 1.0 to 1.5 API/extension points migration guide [message #168123 is a reply to message #168014] Sun, 30 April 2006 17:01 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Sat, 29 Apr 2006 10:47:33 -0400, Max Rydahl Andersen
<max.andersen@jboss.com> wrote:

>
> so, I figured it out and it is *very* suttle!
>
> .....
>
> Can anyone tell me why ? And if it is so, why doesn't something complain
> hard when a content-type id contains dot's ?
>

Max, I don't think its just content type IDs, it should be true for any
extension ID.
For details, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=128866

Funny thing is ... this was the whole reason for the 'a' part of 3.2M5a.
And ... as part of the "workaround" was that the new namespace naming rules
should have an effect only if you update your plugin to say
<?eclipse version="3.2"?>

That is, ID's with dot's should still work if the PI at top of eclipse
plugin
still says <?eclipse version="3.2"?>

(And, BTW, the platform team would say the rule of "no dot's in ID names"
is not not new ... just a new
enforcement of them :)

So, if you did not use 3.2 in PI, that might be worth opening a new bug
related to bug 128866.
If you did use 3.2, then you were not only breaking original syntax rules
on IDs, but you
even asked for the new enforcement of them :)
Re: WTP 1.0 to 1.5 API/extension points migration guide [message #168179 is a reply to message #168123] Mon, 01 May 2006 14:05 Go to previous messageGo to next message
Max Rydahl Andersen is currently offline Max Rydahl Andersen
Messages: 224
Registered: July 2009
Senior Member
>> so, I figured it out and it is *very* suttle!
>>
>> .....
>>
>> Can anyone tell me why ? And if it is so, why doesn't something
>> complain hard when a content-type id contains dot's ?
>>
>
> Max, I don't think its just content type IDs, it should be true for any
> extension ID.
> For details, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=128866

That is the bug thingy I remembered.

> Funny thing is ... this was the whole reason for the 'a' part of 3.2M5a.
> And ... as part of the "workaround" was that the new namespace naming
> rules
> should have an effect only if you update your plugin to say
> <?eclipse version="3.2"?>

I did not update any plugin.xml to 3.2.

> That is, ID's with dot's should still work if the PI at top of eclipse
> plugin
> still says <?eclipse version="3.2"?>
>
> (And, BTW, the platform team would say the rule of "no dot's in ID
> names" is not not new ... just a new
> enforcement of them :)

Which i'm quite fine with; but they could be good sports and make the PDE
editor warn about them ;)

> So, if you did not use 3.2 in PI, that might be worth opening a new bug
> related to bug 128866.
> If you did use 3.2, then you were not only breaking original syntax
> rules on IDs, but you
> even asked for the new enforcement of them :)

blah ;)

i'll open a bug.


--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
Re: WTP 1.0 to 1.5 API/extension points migration guide [message #168193 is a reply to message #168179] Mon, 01 May 2006 14:18 Go to previous message
Max Rydahl Andersen is currently offline Max Rydahl Andersen
Messages: 224
Registered: July 2009
Senior Member
>> So, if you did not use 3.2 in PI, that might be worth opening a new bug
>> related to bug 128866.
>> If you did use 3.2, then you were not only breaking original syntax
>> rules on IDs, but you
>> even asked for the new enforcement of them :)
>
> blah ;)
>
> i'll open a bug.

For the record:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=139491
Previous Topic:WTP Install/Update on Custom Eclipse Application
Next Topic:roject .JETEmitters is missing required library...
Goto Forum:
  


Current Time: Thu Oct 23 09:33:14 GMT 2014

Powered by FUDForum. Page generated in 0.12392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software