Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » seeing a list of wsdl using localhost
seeing a list of wsdl using localhost [message #167100] Wed, 19 April 2006 12:23 Go to next message
plork123 is currently offline plork123
Messages: 174
Registered: July 2009
Senior Member
Hi all

I'm using eclipse 3.1.2 with WTP 1.0.1 - this is the name of the zip file
(wtp-all-in-one-sdk-R-1.0.1-200602171228-win32.zip)

When i right-click my class -> Create Web Service and go through the wizard
it asks me to start Tomcat, I start Tomcat it carries on and my wsdl file is
created

I then go to here http://localhost:8080/MyProject/services and a list of the
wsdl (services) is shown - Great


But if i stop Tomcat and then start it from within Eclipse (not starting
through the Create Web Service wizard) and go to here

http://localhost:8080/MyProject/services i get an HTTP Status 404 error.

Can someone tell me what i need to do, so i can start my Tomcat without
having to start it through the Create Web Service wizard

Many thanks
Re: seeing a list of wsdl using localhost [message #171950 is a reply to message #167100] Wed, 21 June 2006 18:59 Go to previous message
Chris Brealey is currently offline Chris Brealey
Messages: 104
Registered: July 2009
Senior Member
There was a problem with the server-config.wsdd file getting lost between the
workspace and Tomcat, although I don't think an HTTP 404 was the symptom. Please
retry this on WTP 1.0.2 and/or WTP 1.5, and if the problem persists, please open
a bug.

Thanks - CB.

plork123 wrote:

> Hi all
>
> I'm using eclipse 3.1.2 with WTP 1.0.1 - this is the name of the zip file
> (wtp-all-in-one-sdk-R-1.0.1-200602171228-win32.zip)
>
> When i right-click my class -> Create Web Service and go through the wizard
> it asks me to start Tomcat, I start Tomcat it carries on and my wsdl file is
> created
>
> I then go to here http://localhost:8080/MyProject/services and a list of the
> wsdl (services) is shown - Great
>
> But if i stop Tomcat and then start it from within Eclipse (not starting
> through the Create Web Service wizard) and go to here
>
> http://localhost:8080/MyProject/services i get an HTTP Status 404 error.
>
> Can someone tell me what i need to do, so i can start my Tomcat without
> having to start it through the Create Web Service wizard
>
> Many thanks
Previous Topic:problem deploying web service client
Next Topic:open type does not work with wst ui source?
Goto Forum:
  


Current Time: Sun Sep 21 18:26:59 GMT 2014

Powered by FUDForum. Page generated in 0.02074 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software