Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » update problem
update problem [message #1105725] Tue, 10 September 2013 07:54 Go to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Hello,

For the last 3-4 days I was trying to update efxclipse (0.9.0.201309060708) to a newer version (0.9.0.201309100707) using updatesite "http://download.eclipse.org/efxclipse/updates-nightly/site" but I get this error:

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.fx.core,0.9.0.201309100602
No repository found containing: osgi.bundle,org.eclipse.fx.core.guice,0.9.0.201309100602
No repository found containing: osgi.bundle,org.eclipse.fx.formats.svg,0.9.0.201309100602
No repository found containing: osgi.bundle,org.eclipse.fx.ide.converter,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.css,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.css.cssext,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.css.cssext.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.css.jfx,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.css.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.fxgraph,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.fxgraph.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.fxml,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.fxml.compiler,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.java6,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.jdt.core,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.jdt.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.model,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.pde.java7,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.pde.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.pde.ui.e4,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.rrobot,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.rrobot.dsl,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.rrobot.dsl.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.rrobot.model,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.ui,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.ide.ui.preview,0.9.0.201309100707
No repository found containing: osgi.bundle,org.eclipse.fx.javafx,2.2.0.201309100602
No repository found containing: osgi.bundle,org.eclipse.fx.osgi,0.9.0.201309100602
No repository found containing: osgi.bundle,org.eclipse.fx.osgi.util,0.9.0.201309100602
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.all.kepler.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.basic.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.converter.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.css.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.fxgraph.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.fxml.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.pde.feature,0.9.0.201309100707
No repository found containing: org.eclipse.update.feature,org.eclipse.fx.ide.rrobot.feature,0.9.0.201309100707


with Kepler 4.3 64Bit running on Win7 64Bit with JDK1.7_u25 64Bit.
I also made a test with a clean new workspace -> same result.

Any ideas why this error shows up?

Thanks for help!
Re: update problem [message #1105749 is a reply to message #1105725] Tue, 10 September 2013 08:24 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5423
Registered: July 2009
Senior Member
Just gave it a try and it worked for me :-(

Tom

On 10.09.13 09:54, Enrico R. wrote:
> Hello,
>
> For the last 3-4 days I was trying to update efxclipse
> (0.9.0.201309060708) to a newer version (0.9.0.201309100707) using
> updatesite "http://download.eclipse.org/efxclipse/updates-nightly/site"
> but I get this error:
>
>
> An error occurred while collecting items to be installed
> session context was:(profile=SDKProfile,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> No repository found containing:
> osgi.bundle,org.eclipse.fx.core,0.9.0.201309100602
> No repository found containing:
> osgi.bundle,org.eclipse.fx.core.guice,0.9.0.201309100602
> No repository found containing:
> osgi.bundle,org.eclipse.fx.formats.svg,0.9.0.201309100602
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.converter,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.css,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.css.cssext,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.css.cssext.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.css.jfx,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.css.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.fxgraph,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.fxgraph.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.fxml,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.fxml.compiler,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.java6,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.jdt.core,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.jdt.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.model,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.pde.java7,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.pde.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.pde.ui.e4,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.rrobot,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.rrobot.dsl,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.rrobot.dsl.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.rrobot.model,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.ui,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.ide.ui.preview,0.9.0.201309100707
> No repository found containing:
> osgi.bundle,org.eclipse.fx.javafx,2.2.0.201309100602
> No repository found containing:
> osgi.bundle,org.eclipse.fx.osgi,0.9.0.201309100602
> No repository found containing:
> osgi.bundle,org.eclipse.fx.osgi.util,0.9.0.201309100602
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.all.kepler.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.basic.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.converter.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.css.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.fxgraph.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.fxml.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.pde.feature,0.9.0.201309100707
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.fx.ide.rrobot.feature,0.9.0.201309100707
>
>
>
> with Kepler 4.3 64Bit running on Win7 64Bit with JDK1.7_u25 64Bit.
> I also made a test with a clean new workspace -> same result.
>
> Any ideas why this error shows up?
>
> Thanks for help!
Re: update problem [message #1105788 is a reply to message #1105749] Tue, 10 September 2013 09:17 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5423
Registered: July 2009
Senior Member
You can try using the zipped version and try to install it offline.

http://download.eclipse.org/efxclipse/updates-nightly/site_assembly.zip

Tom

On 10.09.13 10:24, Tom Schindl wrote:
> Just gave it a try and it worked for me :-(
>
> Tom
>
> On 10.09.13 09:54, Enrico R. wrote:
>> Hello,
>>
>> For the last 3-4 days I was trying to update efxclipse
>> (0.9.0.201309060708) to a newer version (0.9.0.201309100707) using
>> updatesite "http://download.eclipse.org/efxclipse/updates-nightly/site"
>> but I get this error:
>>
>>
>> An error occurred while collecting items to be installed
>> session context was:(profile=SDKProfile,
>> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
>> action=).
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.core,0.9.0.201309100602
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.core.guice,0.9.0.201309100602
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.formats.svg,0.9.0.201309100602
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.converter,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.css,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.css.cssext,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.css.cssext.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.css.jfx,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.css.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.fxgraph,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.fxgraph.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.fxml,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.fxml.compiler,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.java6,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.jdt.core,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.jdt.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.model,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.pde.java7,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.pde.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.pde.ui.e4,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.rrobot,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.rrobot.dsl,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.rrobot.dsl.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.rrobot.model,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.ui,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.ide.ui.preview,0.9.0.201309100707
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.javafx,2.2.0.201309100602
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.osgi,0.9.0.201309100602
>> No repository found containing:
>> osgi.bundle,org.eclipse.fx.osgi.util,0.9.0.201309100602
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.all.kepler.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.basic.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.converter.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.css.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.fxgraph.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.fxml.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.pde.feature,0.9.0.201309100707
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.fx.ide.rrobot.feature,0.9.0.201309100707
>>
>>
>>
>> with Kepler 4.3 64Bit running on Win7 64Bit with JDK1.7_u25 64Bit.
>> I also made a test with a clean new workspace -> same result.
>>
>> Any ideas why this error shows up?
>>
>> Thanks for help!
>
Re: update problem [message #1107200 is a reply to message #1105788] Thu, 12 September 2013 04:43 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Thomas Schindl wrote on Tue, 10 September 2013 11:17
You can try using the zipped version and try to install it offline.

http://download.eclipse.org/efxclipse/updates-nightly/site_assembly.zip

Tom

The update via ZIP worked. Smile
If this problem occurs again, can I use this URL again to perform an update?

Many thanks Tom!
Re: update problem [message #1107359 is a reply to message #1107200] Thu, 12 September 2013 09:35 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5423
Registered: July 2009
Senior Member
On 12.09.13 06:43, Enrico R. wrote:
> Thomas Schindl wrote on Tue, 10 September 2013 11:17
>> You can try using the zipped version and try to install it offline.
>>
>> http://download.eclipse.org/efxclipse/updates-nightly/site_assembly.zip
>>
>> Tom
>
> The update via ZIP worked. :)
> If this problem occurs again, can I use this URL again to perform an
> update?

For nightlies yes. We'll also publish zip of the final plugin once it is
released under a different URL.

Tom
Previous Topic:Cannot make off-line installation
Next Topic:E4 application project with JavaFX: Maven problem
Goto Forum:
  


Current Time: Sun Oct 26 04:43:42 GMT 2014

Powered by FUDForum. Page generated in 0.02656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software