Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » Native Editor generates an exception
Native Editor generates an exception [message #15714] Tue, 23 June 2009 12:52 Go to next message
Mark D-B is currently offline Mark D-B
Messages: 188
Registered: July 2009
Senior Member
I have created an artifact of "General Document" type. When I change the
Extension attribute, the icon for the artifact changes to the appropriate
one (e.g. Acrobat for pdf, bitmap for bmp, model for mdl).
This would imply to me that OSEE should know which renderer to use.
However, when I right-click->Native Editor, I get:

Tue Jun 23 14:41:15 BST 2009
org.eclipse.osee.framework.ui.skynet.SkynetGui
Plugin
SEVERE org.eclipse.osee.framework.ui.skynet.OpenWithSelectionListen er
widget
Selected (40)
null
java.lang.NullPointerException
at
org.eclipse.osee.framework.jdk.core.util.Lib$1.read(Lib.java :412)
at java.io.InputStream.read(InputStream.java:85)
at
org.eclipse.core.internal.utils.FileUtil.transferStreams(Fil eUtil.jav
a:230)
at
org.eclipse.core.internal.localstore.FileSystemResourceManag er.write(
FileSystemResourceManager.java:932)
at
org.eclipse.core.internal.resources.File.internalSetContents (File.jav
a:330)
at org.eclipse.core.internal.resources.File.create(File.java:15 8)
at org.eclipse.core.internal.resources.File.create(File.java:18 6)
at
org.eclipse.osee.framework.ui.plugin.util.AIFile.writeToFile (AIFile.j
ava:36)
at
org.eclipse.osee.framework.ui.skynet.render.FileRenderer.ren derToFile
(FileRenderer.java:87)
at
org.eclipse.osee.framework.ui.skynet.render.FileRenderer.ren derToFile
System(FileRenderer.java:76)
at
org.eclipse.osee.framework.ui.skynet.render.FileSystemRender er.intern
alOpen(FileSystemRenderer.java:73)
at
org.eclipse.osee.framework.ui.skynet.render.FileSystemRender er.open(F
ileSystemRenderer.java:45)
at
org.eclipse.osee.framework.ui.skynet.commandHandlers.rendere r.handler
s.NativeEditorHandler.execute(NativeEditorHandler.java:33)
at
org.eclipse.ui.internal.handlers.HandlerProxy.execute(Handle rProxy.ja
va:281)
at
org.eclipse.core.commands.Command.executeWithChecks(Command. java:476)

at
org.eclipse.ui.internal.handlers.HandlerService.executeComma nd(Handle
rService.java:178)
at
org.eclipse.osee.framework.ui.skynet.OpenWithSelectionListen er.widget
Selected(OpenWithSelectionListener.java:38)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:
228)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at
org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3823)
at
org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3422)
at
org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.ja
va:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.jav
a:488)
at
org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEAppli
cation.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandl
e.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runAppli
cation(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(Ec
lipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.ja
va:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.ja
va:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.
java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

What's wrong please?
Re: Native Editor generates an exception [message #16152 is a reply to message #15714] Mon, 29 June 2009 04:55 Go to previous messageGo to next message
Mark D-B is currently offline Mark D-B
Messages: 188
Registered: July 2009
Senior Member
Basically, I was being dumb.

OSEE appears (quite reasonably) to need you to use the Artifact Import
Wizard to import an existing document in order to generate a General
Document artifact.
Re: Native Editor generates an exception [message #16297 is a reply to message #16152] Thu, 16 July 2009 23:06 Go to previous message
Ryan D. Brooks is currently offline Ryan D. Brooks
Messages: 100
Registered: July 2009
Senior Member
Mark,

While I have since fixed the specific exception you where getting,
creating a new "General Document" without an import will still not work
properly, so the following bugzilla bug has been created:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=283782.

Thanks,
Ryan


Thanks,
Ryan Brooks
Re: Native Editor generates an exception [message #574193 is a reply to message #15714] Mon, 29 June 2009 04:55 Go to previous message
Mark D-B is currently offline Mark D-B
Messages: 188
Registered: July 2009
Senior Member
Basically, I was being dumb.

OSEE appears (quite reasonably) to need you to use the Artifact Import
Wizard to import an existing document in order to generate a General
Document artifact.
Re: Native Editor generates an exception [message #574466 is a reply to message #16152] Thu, 16 July 2009 23:06 Go to previous message
Ryan D. Brooks is currently offline Ryan D. Brooks
Messages: 100
Registered: July 2009
Senior Member
Mark,

While I have since fixed the specific exception you where getting,
creating a new "General Document" without an import will still not work
properly, so the following bugzilla bug has been created:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=283782

Thanks,
Ryan


Thanks,
Ryan Brooks
Previous Topic:No available factory; defaulting to DefaultArtifactFactory
Next Topic:Artifact type exists but can't create instance
Goto Forum:
  


Current Time: Sat Aug 30 20:31:15 EDT 2014

Powered by FUDForum. Page generated in 0.01823 seconds