Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Problem creating Webservice in WTP 1.0 - Array out of bounds?
Problem creating Webservice in WTP 1.0 - Array out of bounds? [message #166606] Wed, 12 April 2006 13:11 Go to next message
Dave Belfer-Shevett is currently offline Dave Belfer-Shevett
Messages: 9
Registered: July 2009
Junior Member
Hi folks...

I'm trying to get re-started in a webtools-based app that I'm writing for a
client. I had stopped working on servlet stuff for a while to do local
development (in the same Eclipse instance), and all was going fine.

Today I'm trying to re-open an existing project and build it. The problem
is I can't get a new webservice to create.

My Project src folder has com/company/webservices/Sample.java

I right click on the 'Sample.java', go New->Other->Webservice, click okay
and get:

IWAB0014E Unexpected exception occured.
0
java.lang.ArrayIndexOutOfBoundsException: 0
at
org.eclipse.jst.ws.internal.consumption.ui.wsrt.WebServiceRu ntimeExtensionUtils2.getDefaultServerValueFor(WebServiceRunt imeExtensionUtils2.java:511)
at
org.eclipse.jst.ws.internal.creation.ui.widgets.ServerWizard WidgetDefaultingCommand.execute(ServerWizardWidgetDefaulting Command.java:33)
at
org.eclipse.wst.command.internal.env.core.fragment.CommandFr agmentEngine.runCommand(CommandFragmentEngine.java:387)

What am I doing wrong here? I have run my Eclipse Update to make sure I
have the latest of everything. Here's some version information:

Eclipse 3.1.2
Build id: M20060118-1600

WTP Webservice plugin is showing 1.0.1.v200602070050

I've tried trashing the project, recreating it, importing the Sample.java
into it, and then doing "Create webservice" and it fails the same way.

Shoudl I just do a nuke from orbit here? I also have some other plugins
installed (like PHPeclipse), but they shouldn't matter, yes?

Thanks, I'm in quite a bind.. :(

-dbs
Re: Problem creating Webservice in WTP 1.0 - Array out of bounds? [message #166789 is a reply to message #166606] Fri, 14 April 2006 01:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: mcarr67.email.uophx.edu

I was getting the same thing until I defined and configured a server. Once I
did that the problem went away.

--
MICHAEL CARR
"Dave Belfer-Shevett" <dbs@stonekeep.com> wrote in message
news:e1jcal$5nm$1@utils.eclipse.org...
> Hi folks...
>
> I'm trying to get re-started in a webtools-based app that I'm writing for
> a
> client. I had stopped working on servlet stuff for a while to do local
> development (in the same Eclipse instance), and all was going fine.
>
> Today I'm trying to re-open an existing project and build it. The problem
> is I can't get a new webservice to create.
>
> My Project src folder has com/company/webservices/Sample.java
>
> I right click on the 'Sample.java', go New->Other->Webservice, click okay
> and get:
>
> IWAB0014E Unexpected exception occured.
> 0
> java.lang.ArrayIndexOutOfBoundsException: 0
> at
> org.eclipse.jst.ws.internal.consumption.ui.wsrt.WebServiceRu ntimeExtensionUtils2.getDefaultServerValueFor(WebServiceRunt imeExtensionUtils2.java:511)
> at
> org.eclipse.jst.ws.internal.creation.ui.widgets.ServerWizard WidgetDefaultingCommand.execute(ServerWizardWidgetDefaulting Command.java:33)
> at
> org.eclipse.wst.command.internal.env.core.fragment.CommandFr agmentEngine.runCommand(CommandFragmentEngine.java:387)
>
> What am I doing wrong here? I have run my Eclipse Update to make sure I
> have the latest of everything. Here's some version information:
>
> Eclipse 3.1.2
> Build id: M20060118-1600
>
> WTP Webservice plugin is showing 1.0.1.v200602070050
>
> I've tried trashing the project, recreating it, importing the Sample.java
> into it, and then doing "Create webservice" and it fails the same way.
>
> Shoudl I just do a nuke from orbit here? I also have some other plugins
> installed (like PHPeclipse), but they shouldn't matter, yes?
>
> Thanks, I'm in quite a bind.. :(
>
> -dbs
Re: Problem creating Webservice in WTP 1.0 - Array out of bounds? [message #166992 is a reply to message #166789] Tue, 18 April 2006 12:17 Go to previous message
Dave Belfer-Shevett is currently offline Dave Belfer-Shevett
Messages: 9
Registered: July 2009
Junior Member
MICHAEL CARR wrote:
> I was getting the same thing until I defined and configured a server. Once
> I did that the problem went away.

That was in fact the problem - I haven't gotten around to re-posting my
solution. The nutshell is that WTP throws the out of bounds error if you
have no Servers defined in Window->Preferences->Server->Installed Runtimes.

Thanks!

-dbs
Previous Topic:starting websphere from eclipse with security enabled
Next Topic:Is WTP supposed to populate WEB-INF/lib for me?
Goto Forum:
  


Current Time: Sun Aug 31 06:29:05 EDT 2014

Powered by FUDForum. Page generated in 0.03076 seconds