Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Commercial » Disappearing marker problem
Disappearing marker problem [message #15677] Thu, 17 July 2008 03:49 Go to next message
Eclipse User
Originally posted by: snadav.il.ibm.com

I'm developing a plugin for eclipse which allows one to add a comment to a
particular line of code. This is done as an extension to the standard
Editor for Java code, and when a comment is added, my own custom marker
appears in the ruler on the left side of the editor(just like breakpoints).

The bug occurs when adding a comment to the first line of a function. If
the cursor is outside of the function, it works fine-- my marker appears
in the ruler on top of the shading for current scope. However, when the
cursor is within the function, my marker disappears, apparently
overwritten by the start of the shading.

How can I fix this? Is there some layering or priority value for markers
to set what marker appears on top of what?
Re: Disappearing marker problem [message #16115 is a reply to message #15677] Thu, 17 July 2008 10:47 Go to previous message
Eclipse User
Originally posted by: eclipse-news.rizzoweb.com

This question does not belong on the eclipse.commercial newsgroup. Try
eclipse.platform or eclipse.tools.jdt instead.

Nadav wrote:
> I'm developing a plugin for eclipse which allows one to add a comment to
> a particular line of code. This is done as an extension to the standard
> Editor for Java code, and when a comment is added, my own custom marker
> appears in the ruler on the left side of the editor(just like breakpoints).
>
> The bug occurs when adding a comment to the first line of a function.
> If the cursor is outside of the function, it works fine-- my marker
> appears in the ruler on top of the shading for current scope. However,
> when the cursor is within the function, my marker disappears, apparently
> overwritten by the start of the shading.
>
> How can I fix this? Is there some layering or priority value for
> markers to set what marker appears on top of what?
>
>
Re: Disappearing marker problem [message #565699 is a reply to message #15677] Thu, 17 July 2008 10:47 Go to previous message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2233
Registered: July 2009
Senior Member
This question does not belong on the eclipse.commercial newsgroup. Try
eclipse.platform or eclipse.tools.jdt instead.

Nadav wrote:
> I'm developing a plugin for eclipse which allows one to add a comment to
> a particular line of code. This is done as an extension to the standard
> Editor for Java code, and when a comment is added, my own custom marker
> appears in the ruler on the left side of the editor(just like breakpoints).
>
> The bug occurs when adding a comment to the first line of a function.
> If the cursor is outside of the function, it works fine-- my marker
> appears in the ruler on top of the shading for current scope. However,
> when the cursor is within the function, my marker disappears, apparently
> overwritten by the start of the shading.
>
> How can I fix this? Is there some layering or priority value for
> markers to set what marker appears on top of what?
>
>
Previous Topic:[ANN] openArchitectureWare and EMF training now available in the UK
Next Topic:Team Update CVS command
Goto Forum:
  


Current Time: Fri Aug 29 06:14:25 EDT 2014

Powered by FUDForum. Page generated in 0.02275 seconds