Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Erros when running unit tests on WTP plug-ins
Erros when running unit tests on WTP plug-ins [message #166072] Thu, 06 April 2006 12:05 Go to next message
Eclipse User
Originally posted by: qa3820.hotmail.com

Hi,
According to
http://download.eclipse.org/webtools/downloads/drops/R-1.0.1 -200602171228/testResults.php,
there's no errors & failures in WTP 1.0.1. But I did encounter an error when
I ran the unit tests.
I downloaded the wtp all in one package for windows, added
wtp-wst-Automated-Tests-1.0.zip file (from
http://www.eclipse.org/downloads/download.php?file=/webtools /downloads/drops/R-1.0-200512210855/wtp-wst-Automated-Tests- 1.0.zip)
and eclipse-test-framework-3.1.zip.
When I ran DataModel UI API Tests -> TestWizardTestcase -> testSimpleWizard
test, I got the following result:

testSimpleWizard(org.eclipse.wst.common.tests.ui.wizard.Test WizardTestcase):
Invalid thread access

org.eclipse.swt.SWTException: Invalid thread access
at org.eclipse.swt.SWT.error(SWT.java:2942)
at org.eclipse.swt.SWT.error(SWT.java:2865)
at org.eclipse.swt.SWT.error(SWT.java:2836)
at org.eclipse.swt.widgets.Widget.error(Widget.java:395)

and the stack trace goes on...

How come that when I ran these tests I did get error?

Thank you,
Moty
Re: Erros when running unit tests on WTP plug-ins [message #166442 is a reply to message #166072] Tue, 11 April 2006 12:47 Go to previous message
Lawrence Mandel is currently offline Lawrence Mandel
Messages: 486
Registered: July 2009
Senior Member
Hi Moty,

I don't have a specific answer for this test but encourage you to open a
bug against the Web Tools -> wst.common component so the owner can take a
look. These tests should pass on all systems.

Lawrence
Previous Topic:Need in running Junit wst tests when using new plug-ins with wst
Next Topic:How can I get source code using wincvs
Goto Forum:
  


Current Time: Wed Jul 23 01:51:18 EDT 2014

Powered by FUDForum. Page generated in 0.12933 seconds