Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Installing JDT plugins offline into Eclipse CDT
Installing JDT plugins offline into Eclipse CDT [message #1102271] Thu, 05 September 2013 15:30 Go to next message
jonathan knez is currently offline jonathan knezFriend
Messages: 2
Registered: September 2013
Junior Member
I have an existing Eclipse CDT installation (Eclipse IDE for C/C++ Developers). It is version 4.2, Juno. I want to add java support via JDT. To makes things slightly more complex, the machines running Ecilpse are on a private LAN with no internet access.

So far I have not been able to find an update repository for the JDT plugins. Other plugins I have needed, I simply downloaded the zip from their update repository, copied the zip to the offline machines, then added it using "install new software" from archive. Does anyone know where I can download the corresponding zip files for JDT?

As a fall back, I created a mirror of the main 4.2 Juno repository (http://download.eclipse.org/eclipse/updates/4.2) using P2 as outlined here. I had assumed JDT would be part of the main project but I was wrong. JDT does not appear in the mirrored site. Does anyone know the correct repository URL to get JDT?

I feel like I am taking crazy pills. I cant figure out how to get JDT offline without downloading an Eclipse package that comes with it bundled. I appreciate any help.
Re: Installing JDT plugins offline into Eclipse CDT [message #1102529 is a reply to message #1102271] Thu, 05 September 2013 21:37 Go to previous message
jonathan knez is currently offline jonathan knezFriend
Messages: 2
Registered: September 2013
Junior Member
I found the right repository address, or what I thought was the right one. I used http://download.eclipse.org/releases/juno. Just for the sake of completeness, here are the commands to create a mirror of the repository when run on a Windows platform. All other platforms use eclipse rather than ecipsec.

eclipsec -nosplash -verbose application org.eclipse.equinox.p2.metadata.repository.mirrorApplication
 -source http://download.eclipse.org/releases/juno
 -destination c:\4_2_mirror

eclipsec -nosplash -verbose -application org.eclipse.equinox.p2.artifact.repository.mirrorApplication
 -source http://download.eclipse.org/releases/juno
 -destination c:\4_2_mirror


So now I have my repository on DVD and I go to install Eclipse Java Development Tools. The installation begins but errors out with the following message.

Quote:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.ant.ui,3.5.301.v20121210-210948
No repository found containing: osgi.bundle,org.eclipse.jdt.annotation,1.0.1.v20130111-135246
No repository found containing: osgi.bundle,org.eclipse.jdt.apt.pluggable.core,1.0.400.v20120522-1651
No repository found containing: osgi.bundle,org.eclipse.jdt.compiler.tool,1.0.200.v20130116-050536
No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.8.3.v20130121-145325
No repository found containing: osgi.bundle,org.eclipse.jdt.junit,3.7.100.v20120523-1543
No repository found containing: osgi.bundle,org.eclipse.jdt.junit.core,3.7.100.v20120523-1257
No repository found containing: osgi.bundle,org.eclipse.jdt.ui,3.8.2.v20130107-165834
No repository found containing: binary,org.eclipse.jdt_root,3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83
No repository found containing: osgi.bundle,org.hamcrest.core,1.1.0.v20090501071000


I guess there are some required packages that were not part of the mirror.

Regardless, I think I will simply install a second instance of Eclipse rather than continuing to try to add JDT support to a CDT installation.
Previous Topic:Migrate to Ecplise Compiler
Next Topic:EclipseCompiler working standalone but not in plugin
Goto Forum:
  


Current Time: Sat Dec 20 14:40:46 GMT 2014

Powered by FUDForum. Page generated in 0.01672 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software