Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Validate XML File: No grammar constraints detected
Validate XML File: No grammar constraints detected [message #165385] Thu, 30 March 2006 11:13 Go to next message
Eclipse User
Originally posted by: born.oio.de

Hi,

i've got a XML File with XSD (without Namespace). Sth. like that:

<?xml version="1.0" encoding="UTF-8"?>
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="../src/xml-schema/article.xsd ">
<head>head</head>
<article/>
</page>

(generated stub)

Eclipse and WTP are suggesting possible Elements (knowing the strucutre),
but if i try to validate: "The XML File is well formed. Warning: No
grammar constraints detected for the document"

Can any body tell me wy?

Thx!

Der Matze
Re: Validate XML File: No grammar constraints detected [message #165457 is a reply to message #165385] Thu, 30 March 2006 19:11 Go to previous messageGo to next message
Marc Adams is currently offline Marc Adams
Messages: 15
Registered: July 2009
Junior Member
Matthias Born wrote:
> Hi,
>
> i've got a XML File with XSD (without Namespace). Sth. like that:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:noNamespaceSchemaLocation="../src/xml-schema/article.xsd ">
> <head>head</head>
> <article/>
> </page>
>
> (generated stub)
>
> Eclipse and WTP are suggesting possible Elements (knowing the
> strucutre), but if i try to validate: "The XML File is well formed.
> Warning: No grammar constraints detected for the document"
>
> Can any body tell me wy?
>
> Thx!
>
> Der Matze
>

That does sound interesting. I've never done a no namespace schema so my
insight might not be completely informed. Have you tried closing the XML
file, re-opening it and running the validator? Sometimes that works out
some of the kinks inthe editor behavior for me.
Re: Validate XML File: No grammar constraints detected [message #165464 is a reply to message #165457] Thu, 30 March 2006 23:13 Go to previous messageGo to next message
Craig Salter is currently offline Craig Salter
Messages: 169
Registered: July 2009
Senior Member
This used to work nicely a while back. I believe this is a bug
(regression) in our XML Validator. See bug 133093.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=133093
Re: Validate XML File: No grammar constraints detected [message #165488 is a reply to message #165464] Fri, 31 March 2006 04:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: born.oio.de

yes, craig is right.

it worked fine before wtp 1.0. (0.7 ore sth. i can't remember)

my stub was only an example for you, the original files are much more
complex. these files were opened and closed very often, so i'm shure, that
wouldn'd solve my problem.

are you shure, that adding a namespace (targetNamespace) to the schema
will solve the problem. i must know this before changing all schema and
sources.

thx!

matze
Re: Validate XML File: No grammar constraints detected [message #166404 is a reply to message #165488] Tue, 11 April 2006 12:18 Go to previous message
Lawrence Mandel is currently offline Lawrence Mandel
Messages: 486
Registered: July 2009
Senior Member
Things look to be working fine when a namespace is in use. I'll get this
bug fixed in the 1.5 timeframe as your scenario should work and, as you
pointed out, used to work in WTP.

Lawrence
Previous Topic:Eclipse book recommendation!
Next Topic:Window > Preferences > Web Tools > New J2EE Project.
Goto Forum:
  


Current Time: Wed Aug 27 13:10:04 EDT 2014

Powered by FUDForum. Page generated in 0.59119 seconds