Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP War Deployment Issue
RAP War Deployment Issue [message #1097211] Thu, 29 August 2013 11:35 Go to next message
Sascha Smoo is currently offline Sascha Smoo
Messages: 55
Registered: November 2012
Member
Hello,

I'm trying to deploy my RAP2.1 application to a tomcat7 server. The war file looks good, the osgi console says all bundles are loaded but when I try to access my App via "http://localhost:8080/DocBot/DocBot I get the following exception message:

java.lang.IllegalArgumentException: Illegal theme id: WorkerChainEditor.model.editor.badtheme
	org.eclipse.rap.rwt.internal.service.UISessionBuilder.verifyThemeId(UISessionBuilder.java:70)
	org.eclipse.rap.rwt.internal.service.UISessionBuilder.setCurrentTheme(UISessionBuilder.java:55)
	org.eclipse.rap.rwt.internal.service.UISessionBuilder.buildUISession(UISessionBuilder.java:46)
	org.eclipse.rap.rwt.engine.RWTServlet.ensureUISession(RWTServlet.java:141)
	org.eclipse.rap.rwt.engine.RWTServlet.handleValidRequest(RWTServlet.java:118)
	org.eclipse.rap.rwt.engine.RWTServlet.handleRequest(RWTServlet.java:106)
	org.eclipse.rap.rwt.engine.RWTServlet.doGet(RWTServlet.java:92)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
	org.eclipse.rap.rwt.osgi.internal.CutOffContextPathWrapper.service(CutOffContextPathWrapper.java:106)
	org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
	org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128)
	org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
	org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:138)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:728)


Anyone knows that's wrong? If I start my app inside of Eclipse everything works fine. The theme is defined in the extensions using the org.eclipse.rap.ui.branding and set to the rap.ui.entrypoint.

Greetings,
Sascha
Re: RAP War Deployment Issue [message #1097243 is a reply to message #1097211] Thu, 29 August 2013 12:33 Go to previous message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
Hi,
this error means that the theme with id
"WorkerChainEditor.model.editor.badtheme" is not registered in the
ThemeManager. Where the theme is located (separate bundle)? Is this
bundle included into the WAR?
Best,
Ivan

On 8/29/2013 2:35 PM, Sascha Smoo wrote:
> Hello,
>
> I'm trying to deploy my RAP2.1 application to a tomcat7 server. The
> war file looks good, the osgi console says all bundles are loaded but
> when I try to access my App via "http://localhost:8080/DocBot/DocBot I
> get the following exception message:
>
>
> java.lang.IllegalArgumentException: Illegal theme id:
> WorkerChainEditor.model.editor.badtheme
> org.eclipse.rap.rwt.internal.service.UISessionBuilder.verifyThemeId(UISessionBuilder.java:70)
>
> org.eclipse.rap.rwt.internal.service.UISessionBuilder.setCurrentTheme(UISessionBuilder.java:55)
>
> org.eclipse.rap.rwt.internal.service.UISessionBuilder.buildUISession(UISessionBuilder.java:46)
>
> org.eclipse.rap.rwt.engine.RWTServlet.ensureUISession(RWTServlet.java:141)
>
> org.eclipse.rap.rwt.engine.RWTServlet.handleValidRequest(RWTServlet.java:118)
>
> org.eclipse.rap.rwt.engine.RWTServlet.handleRequest(RWTServlet.java:106)
>
> org.eclipse.rap.rwt.engine.RWTServlet.doGet(RWTServlet.java:92)
> javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
> javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
> org.eclipse.rap.rwt.osgi.internal.CutOffContextPathWrapper.service(CutOffContextPathWrapper.java:106)
>
> org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
>
> org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128)
>
> org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60)
>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
> org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:138)
>
> javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
>
>
> Anyone knows that's wrong? If I start my app inside of Eclipse
> everything works fine. The theme is defined in the extensions using
> the org.eclipse.rap.ui.branding and set to the rap.ui.entrypoint.
>
> Greetings,
> Sascha

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Hybrid RAP based target plateform to share
Next Topic:HTTP POST request problems with RAP 2.0
Goto Forum:
  


Current Time: Sun Oct 26 05:16:43 GMT 2014

Powered by FUDForum. Page generated in 0.07666 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software