Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » Running the app_server
Running the app_server [message #15469] Sun, 31 May 2009 03:34 Go to next message
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
I am trying to get the app server running on a Windows Xp box. I am using
the method MarkDB has shown. All components are on one box but I am
running it as a remote server.

The xml file has the port as 5432 but the pg_log says 4120 and says the
target machine actively refuses connection.

The xml connection file is:

<DbConnection>

<DatabaseInfo id="postgresqlInfo">
<DatabaseHome key="#DBHOME#"/>
<DatabaseName key="#DBNAME#" value="OSEE" />
<DatabaseType key="#TYPE#" value="postgresql" />
<Prefix key="#PREFIX#" value="jdbc:postgresql" />
<UserName key="#USERNAME#" value="osee" />
<Password key="#PASSWORD#" value="osee" />
<Host key="#HOST#" value="@AvailableDbServices.hostAddress" />
<Port key="#PORT#" value="@AvailableDbServices.port" />
</DatabaseInfo>

<ConnectionDescription id="postgresql" >
<Driver>org.postgresql.Driver</Driver>
<Url>#PREFIX#://#HOST#:#PORT#/#DBHOME##DBNAME#</Url>
</ConnectionDescription>

<AvailableDbServices>
<Server id="OSEE" dbInfo="postgresqlInfo"
hostAddress="127.0.0.1" port="5432"
connectsWith="postgresql" isProduction="false" />
</AvailableDbServices>
</DbConnection>


The pg_log file is:

LOG: connection received: host=127.0.0.1 port=4120
LOG: connection authorized: user=osee database=OSEE
ERROR: relation "osee_join_artifact" does not exist
STATEMENT: DELETE FROM osee_join_artifact WHERE insert_time < $1
LOG: could not receive data from client: No connection could be made
because the target machine actively refused it.
LOG: unexpected EOF on client connection
LOG: disconnection: session time: 0:15:17.069 user=osee database=OSEE
host=127.0.0.1 port=4120

The reported port number changes each time script is run.

Any suggestions on how to proceed?

Ray
Re: Running the app_server [message #15534 is a reply to message #15469] Mon, 01 June 2009 18:49 Go to previous messageGo to next message
Mark D-B is currently offline Mark D-BFriend
Messages: 188
Registered: July 2009
Senior Member
Hi Ray,

I'm looking at this from home at the moment, so don't have access to my
notes. I think I got something similar to this if I didn't add 127.0.0.1
to the list of permitted machines in PGAdmin. There's a file with a name
which I've forgotten which determines the list of machines that can
connect. By default, it only allows the local machine to connect and the
remote clients are treated as external even if running on the same
machine. Click on the OSEE database in PGAdmin and then go to the tools
menu. There is an option on there to edit the access control file and you
need to open up 127.0.0.1.
This may be a red herring as it was a month or so ago that I had the
similar problem.
Re: Running the app_server [message #15566 is a reply to message #15534] Mon, 01 June 2009 20:58 Go to previous message
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
Mark,

I belive I have the local IP covered. The existing configuration is
below.
The pg_hba.conf file includes the following lines:
host all all 127.0.0.1/32 trust
host all all xx.xx.xx.x/32 trust (my IP address)
host all all Mycomp trust (my computer's name on the
network)

The postgresql.conf file has:
listen_address = '*'

The Windows host file has:
127.0.0.1 localhost
127.0.0.1 Mycomp

Any idea what else I might look at?

I have been trying this on three different machines. On the one I am on
right now, I can not find the Eclipse OSEE log file. On my other
machines, it shows up in osee/app_svr/configuration/xx.log. Any idea how
I can locate/force the log?

Ray
Re: Running the app_server [message #574012 is a reply to message #15469] Mon, 01 June 2009 18:49 Go to previous message
Mark D-B is currently offline Mark D-BFriend
Messages: 188
Registered: July 2009
Senior Member
Hi Ray,

I'm looking at this from home at the moment, so don't have access to my
notes. I think I got something similar to this if I didn't add 127.0.0.1
to the list of permitted machines in PGAdmin. There's a file with a name
which I've forgotten which determines the list of machines that can
connect. By default, it only allows the local machine to connect and the
remote clients are treated as external even if running on the same
machine. Click on the OSEE database in PGAdmin and then go to the tools
menu. There is an option on there to edit the access control file and you
need to open up 127.0.0.1.
This may be a red herring as it was a month or so ago that I had the
similar problem.
Re: Running the app_server [message #574037 is a reply to message #15534] Mon, 01 June 2009 20:58 Go to previous message
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
Mark,

I belive I have the local IP covered. The existing configuration is
below.
The pg_hba.conf file includes the following lines:
host all all 127.0.0.1/32 trust
host all all xx.xx.xx.x/32 trust (my IP address)
host all all Mycomp trust (my computer's name on the
network)

The postgresql.conf file has:
listen_address = '*'

The Windows host file has:
127.0.0.1 localhost
127.0.0.1 Mycomp

Any idea what else I might look at?

I have been trying this on three different machines. On the one I am on
right now, I can not find the Eclipse OSEE log file. On my other
machines, it shows up in osee/app_svr/configuration/xx.log. Any idea how
I can locate/force the log?

Ray
Previous Topic:Running the app_server
Next Topic:Getting client/server running - worked for me
Goto Forum:
  


Current Time: Fri Nov 28 07:30:59 GMT 2014

Powered by FUDForum. Page generated in 0.06754 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software