Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Help with tutorial(Noob question)
Help with tutorial [message #1095915] Tue, 27 August 2013 14:06 Go to next message
Victor Lopez is currently offline Victor Lopez
Messages: 21
Registered: August 2013
Junior Member
Hello everybody,

I will ask something easy for you but I am stuck and I would like to continue.

I have followed the attached tutorial. Same names same everything. The only thing is when I am adding plugin dependencies, it cannot find org.eclipse.graphiti.mm. What it finds is org.eclipse.graphiti.mm.source and I dont know if it is the same.

Then I run the project and when I create a new Diagram, my example does not exist in the combo box.

Any ideas? I would be so grateful.

Best regards,

-> Vic.
Re: Help with tutorial [message #1096276 is a reply to message #1095915] Wed, 28 August 2013 03:13 Go to previous messageGo to next message
Michael Wenz is currently offline Michael Wenz
Messages: 1527
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Vic,

if you have a dependency to org.eeclipse.graphiti / org.eclipse.graphiti.ui then the dependencies are fine. These plugins export their own dependency to org.eclipse.graphiti.mm (that's the reason why you can't enter it).

Something else must be wrong if you don't see your diagram type. Have you checked the Eclipse error log?

Michael
Re: Help with tutorial [message #1096628 is a reply to message #1096276] Wed, 28 August 2013 12:54 Go to previous messageGo to next message
Victor Lopez is currently offline Victor Lopez
Messages: 21
Registered: August 2013
Junior Member
mmmm OK, when I deleted mm.source plugin, everything worked ok!

Thanks!

[Updated on: Wed, 28 August 2013 13:04]

Report message to a moderator

Re: Help with tutorial [message #1097053 is a reply to message #1096628] Thu, 29 August 2013 03:15 Go to previous message
Michael Wenz is currently offline Michael Wenz
Messages: 1527
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Not sure what exactly, but there seems to be something wrong with your
plugin org.ancit.examples.graphiti 1.0.0. Maybe the details of the message
that this bundle cannot be resolved could give a clue.

Michael
Previous Topic:tree view in graphiti
Next Topic:Copy And Paste of graphical Elements
Goto Forum:
  


Current Time: Sun Apr 20 16:05:34 EDT 2014

Powered by FUDForum. Page generated in 0.01574 seconds