Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMW » Mwcore validation
Mwcore validation [message #1094835] Mon, 26 August 2013 05:00 Go to next message
Giacomo Lamonaco is currently offline Giacomo Lamonaco
Messages: 5
Registered: July 2012
Junior Member
hi all,

i'm extending the mwcore metamodel, creating a new one called 'mapping'. My goal is to obtain the mapping.genmodel file: it is necessary because i want the extend the default weaving panel and i need to embed artifacts previously generated. However, during the genmodel wizard, i receive an error: it is related to the validation process; in fact, i can replicate this error using the validation tool.

index.php/fa/16032/0/
if you've problem with the image, try imageshack.us/photo/my-images/22/y6kt.png/

The error message is showed below: it refers to some properties of the mwcore metamodel.

index.php/fa/16033/0/
if you've problem with the image, try imageshack.us/photo/my-images/547/7dib.png/

How can i solve this problem?

Thanks
  • Attachment: Immagine.png
    (Size: 8.06KB, Downloaded 121 times)
  • Attachment: Immagine3.png
    (Size: 20.54KB, Downloaded 116 times)
Re: Mwcore validation [message #1095244 is a reply to message #1094835] Mon, 26 August 2013 16:41 Go to previous message
Marcos Didonet Del Fabro is currently offline Marcos Didonet Del Fabro
Messages: 15
Registered: June 2011
Junior Member
Hello

did you create an extension to the mwcore metamodel?

This metamodel has only abstract elements, so it's elements cannot be directly instantiated. You need to create an element that inherits from WModel.



Regards,

Marcos.
Previous Topic:Woven Panel Extension [Solved]
Goto Forum:
  


Current Time: Fri Apr 18 10:07:33 EDT 2014

Powered by FUDForum. Page generated in 0.08023 seconds