Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » problem installing guidancer on an old indigo eclipse
problem installing guidancer on an old indigo eclipse [message #1092275] Thu, 22 August 2013 14:59 Go to next message
Tom Brus is currently offline Tom BrusFriend
Messages: 25
Registered: February 2011
Junior Member
Hi,

I am trying to make a gef extension for guidancer/jubula for our application. We are still running an old indigo eclipse for our development for various reasons. I have guidancer 7.0.00056 at the moment and I am trying to install the "Jubula Remote Control SDK" feature from the guidancer install dir: .../guidancer_7.0.00056/development/extension-toolkit-rc.zip.

This does not work because I get the following error:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Jubula Remote Control SDK 2.0.0.201303141505 (org.eclipse.jubula.feature.rc.feature.group 2.0.0.201303141505)
  Missing requirement: Jubula Remote Control - RCP e4 SWT 2.0.0.201303141505 (org.eclipse.jubula.rc.rcp.e4.swt 2.0.0.201303141505) requires 'bundle org.eclipse.e4.ui.workbench [0.10.2,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Jubula Remote Control SDK 2.0.0.201303141505 (org.eclipse.jubula.feature.rc.feature.group 2.0.0.201303141505)
    To: org.eclipse.jubula.rc.rcp.e4.swt [2.0.0.201303141505]

Be aware that the error message mentions e4 bundles but indigo is still e3, right? I can not use (and do not want) e4 bundles I guess.

My questions:

  1. Do I need to install this feature to be able to build a GEF extension?
  2. Is it at all possible to use this combination of versions?


Grateful for any hints here.

Tom

[Updated on: Thu, 22 August 2013 15:17]

Report message to a moderator

Re: problem installing guidancer on an old indigo eclipse [message #1093068 is a reply to message #1092275] Fri, 23 August 2013 14:14 Go to previous messageGo to next message
Tom Brus is currently offline Tom BrusFriend
Messages: 25
Registered: February 2011
Junior Member
I solved my problem without installing the feature after all. For those stumbling on something similar, this is what I did:

I extracted the org.eclipse.jubula.rc.rcp.e3_2.0.0.201303141505.jar and put it in a lib dir in my project.
Then I added that lib dir to my target definition. Now the compiler can find the correct classes.

Part of the problems seems to be that the rcp-support.zip in the guidancer installation contains one OSGI bundle (org.eclipse.jubula.rc.rcp_2.0.0.201303141505) that dynamically installs the correct jubula plugins it has in its belly, probably based on the version of the eclipse it is running in. The above mentioned jar is one of those plugins (containing IEditPartIdentifier, which I need).

This all seems to work but I am not sure if this is the preferred way. I had an old Guidancer V5 gef extension that I started with so I did not exactly follow the manual on this one Wink. Please correct me if I am taking a wrong turn somewhere.

Thanks,
Tom
Re: problem installing guidancer on an old indigo eclipse [message #1097776 is a reply to message #1093068] Fri, 30 August 2013 06:36 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1169
Registered: July 2009
Senior Member
Thanks for updating Tom Smile
Previous Topic:Extending Jubula to select tabbed properties in tabbed property pages
Next Topic:Simicolon (Key Combination)
Goto Forum:
  


Current Time: Sat Nov 29 07:53:47 GMT 2014

Powered by FUDForum. Page generated in 0.02303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software